digital dash malfunction - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler Electrical Discussions Arctic Cat Prowler electrical discussions.
Lighting, audio, GPS, communications, etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 12-08-2008, 02:07 PM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
Question digital dash malfunction

My 06 xt has been a very good machine, but recently the digital dash has been acting up. Occasionally I will be running along and the dash will shut off and only the word volt will come up. The only way to get it off is to turn the key off. Only for a second but it still has to be turned off. Anyone have any suggestions. I was told that the battery may be low,but i have one of those static batteries from hunterworks and it is fully charged. Any help would be appreciated. I have an xtz ordered but i would like to have it fixed for the new owner.
prowlerbob is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 12-08-2008, 05:16 PM
Founding Member
 
warlock's Avatar
 
Join Date: Sep 2008
Posts: 338
 
I think I still have another prowler dash if you need one.
warlock is offline  
post #3 of 23 (permalink) Old 12-09-2008, 09:06 AM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
dash malfunction

Thanks Warlock. If i can't get this one fixed i will be interested in yours. Waiting on some info so maybe a easy fix.Give me a few days to see if anyone has anything to offer.
prowlerbob is offline  
 
post #4 of 23 (permalink) Old 12-09-2008, 10:57 AM
Junior Member
 
Join Date: Nov 2008
Posts: 1
 
check the fuses under the seat.. my 08 xtx seems to do the same thing once and a while, and i've narrowed it down to the fuses coming almost out of the holder
oilbuner6-5 is offline  
post #5 of 23 (permalink) Old 12-09-2008, 04:06 PM
Founding Member
 
plowboy's Avatar
 
Join Date: Oct 2008
Posts: 85
 
Quote:
Originally Posted by prowlerbob View Post
My 06 xt has been a very good machine, but recently the digital dash has been acting up. Occasionally I will be running along and the dash will shut off and only the word volt will come up. The only way to get it off is to turn the key off. Only for a second but it still has to be turned off. Anyone have any suggestions. I was told that the battery may be low,but i have one of those static batteries from hunterworks and it is fully charged. Any help would be appreciated. I have an xtz ordered but i would like to have it fixed for the new owner.
had it happen to mine if i use too much juice...running lights , heater , wiper at same time and letting it idle too long while doing something like fix a fence. or if I use sprayer and just putt around spraying and use too much voltage. I just charge battery back up and am good to go

2008 Prowler XTX
full cab
4-ITP 15"SS 112 rims
33x10.5-15 thornbirds on all four corners
suspension built by diecastplaycars.com
6" Over Long Travel Suspension-jacked up 5"
sportin' 19" of ground clearance
plowboy is offline  
post #6 of 23 (permalink) Old 12-09-2008, 09:26 PM
Founding Member
 
warlock's Avatar
 
Join Date: Sep 2008
Posts: 338
 
Hey guys theres a great big spot under the drivers seat to put a full size battery just need to move a few little things.
warlock is offline  
post #7 of 23 (permalink) Old 02-21-2015, 11:09 AM
New Member
 
Join Date: Dec 2011
Location: Minnesota
Posts: 21
 
Has anyone had the dash light up but not display anything??
hotrod is offline  
post #8 of 23 (permalink) Old 02-21-2015, 11:13 AM
New Member
 
Join Date: Dec 2011
Location: Minnesota
Posts: 21
 
DigitalDash

I have a 2012 HDX and the dash lights up but does not display anything. I have checked the fuses and they look ok, any ideas??
hotrod is offline  
post #9 of 23 (permalink) Old 02-21-2015, 01:17 PM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,108
 
Looking back, it seems the mostly culprit is low voltage, battery should have 12.5 to 12.8 volts with the engine off, running should jump up to 14.5 to 15 volts with no lights or accessories turned on. Has this been a reoccurring issue?

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #10 of 23 (permalink) Old 02-21-2015, 01:26 PM
Lifetime Member
 
mlh1962's Avatar
 
Join Date: Jul 2011
Location: Lexington, Missouri
Posts: 3,621
 
Garage
Occasionally my speedometer drops to 0 and won't work again until I shut it off, no problem with rpm mode.

'07 Prowler 650 H1 XT, L.E.D. stop/turn signals, Summit Racing heater, AC winch, AC windshield, soft cab & doors, 6' Eagle Plow, oil gauge, Maxxis MT-762 truck tires, AC Fender Flares, E-Brake alarm, Yutrax UTV Jump Seat, Dynatek CDI
Missouri Mike
mlh1962 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
digital dash Haus720 Arctic Cat Prowler Electrical Discussions 14 02-24-2015 04:41 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67