Charging/starting problem - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler Electrical Discussions Arctic Cat Prowler electrical discussions.
Lighting, audio, GPS, communications, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-08-2009, 09:04 PM Thread Starter
Junior Member
 
Join Date: Jan 2009
Posts: 10
 
Charging/starting problem

I have a 2008 650 xt. I recently bought a new battery in november, a Odyssey pc680 drycell. After charging 2amp for 2 days my cat will start and run fine, turned it off and restarted fine but was flashing "volt" on dash. Is my stator bad? I hope not those things are a little pricey. Any ideas, or ways to test something would be very helpful. Thanks
02jeeperx is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-09-2009, 08:07 AM
Senior Member
 
Johnny's Avatar
 
Join Date: Jan 2009
Posts: 438
 
just put a volt meter on the battery running then push the gas pedal and rev her up alittle you should see the volts go up to atleast 12.9 to 14 if no id say you have a charging problem

623-934-3070
Please understand we support many forums and cant keep up with Private messages or questions on the forum boards so
If you have a question Please Call the Retail Shop 623-934-3070
Johnny is offline  
post #3 of 5 (permalink) Old 04-09-2009, 10:29 AM
Junior Member
 
NoahTM02's Avatar
 
Join Date: Nov 2008
Location: ohio
Posts: 46
 
my 07 650 is kind of doin the samething. if i dont run it every couple days the battery wont have enuff juice to start it.. so i usually just put it on a 2 amp charger for an hour and its good to go
NoahTM02 is offline  
 
post #4 of 5 (permalink) Old 04-09-2009, 11:00 AM
Junior Member
 
Join Date: Nov 2008
Posts: 39
 
Make sure the battery (amps & volts) has the correct spec's by the mfg. Not all batteries for ATV's are the same. We have used Two different mfg. types of ATV batteries and have found that the specs were way different from one another. I hope this will help!!!!
Diecast is offline  
post #5 of 5 (permalink) Old 04-11-2009, 02:27 AM Thread Starter
Junior Member
 
Join Date: Jan 2009
Posts: 10
 
Thanks for the tips, I will try these and let you guys know.
02jeeperx is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard starting racecarfanatic5 Arctic Cat Prowler General Discussions 36 05-15-2013 02:21 PM
Starting problems PROWLER 21 Arctic Cat Prowler General Discussions 43 01-10-2011 06:31 AM
Starting Problem 02jeeperx Arctic Cat Prowler General Discussions 26 05-26-2010 06:57 AM
2006 Prowler brake problem Desertcat Arctic Cat Prowler Safety Discussions 26 06-30-2009 08:53 AM
Charging light indicator ametric Arctic Cat Prowler Electrical Discussions 0 02-23-2009 12:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67