light shenanigans - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler Electrical Discussions Arctic Cat Prowler electrical discussions.
Lighting, audio, GPS, communications, etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 11-11-2012, 07:34 PM Thread Starter
Jounior Member
 
blowinsoot00's Avatar
 
Join Date: Jul 2012
Location: Goodyear Az
Posts: 250
 
Question light shenanigans

ok so i got my clutch system back together, got the dynatek cdi, fuel controller, and ignition coil all put on and running great...theres only one catch...now when i hit my brakes i illuminate the dark with all of my headlights, ive pulled the light fuse and they still come on with brake engagement, key off nothing works, key on or running brake switch turns on all forward lights on....ive looked over all the dynatek wiring everything is good, short of calling a old priest and a young nun i dont know where to go from here. if i disconnect the brake switch it doesnt do it and all is normal just no brake lights. HELP

09 xtx- custom fox 2.0 air shocks- bighorn tires- custom paint- 4 seat cage built by me- soft top- twisted stitch seats- half doors- intake built by me- magnaflow exhaust built by me- carillo 4 point harnesses all around- 5 h.i.d.'s- clutch kit- dynatek- no more turf saver...tig welded now- 2" wheel spacers- ss-212 rims in black-
blowinsoot00 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 11-12-2012, 03:46 AM
Senior Member
 
Diesel Racer's Avatar
 
Join Date: Dec 2010
Location: NH
Posts: 799
 
Recheck your wiring taps.



Tim

2010 A/C XTZ with some "Stuff" SOLD
But still here everyday to contribute to the cause
Diesel Racer is offline  
post #3 of 12 (permalink) Old 11-12-2012, 06:14 PM Thread Starter
Jounior Member
 
blowinsoot00's Avatar
 
Join Date: Jul 2012
Location: Goodyear Az
Posts: 250
 
There's no taps on the xtx, all plug and play, this thing rips on dirt now, will spin the tires for a good 30 foot if i lay into it, would never spin em before, i went over all the wiring and all are plugged in and tight. Also my idle is at 2000rpm and the fuel controller won't bring it down....it well idle at 1400 till i blip the thrrottle after starting, then its 2000 till i shut it down and restart it then back to 1400 then to 2000 after a blip...

09 xtx- custom fox 2.0 air shocks- bighorn tires- custom paint- 4 seat cage built by me- soft top- twisted stitch seats- half doors- intake built by me- magnaflow exhaust built by me- carillo 4 point harnesses all around- 5 h.i.d.'s- clutch kit- dynatek- no more turf saver...tig welded now- 2" wheel spacers- ss-212 rims in black-
blowinsoot00 is offline  
 
post #4 of 12 (permalink) Old 11-12-2012, 06:42 PM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
sounds like it runs good,DJ it sounds to me like its running to lean could be controller.I know your F/I when i changed to a different carb mine did the same thing i would shut it off re start idle at 1300 to 1400 hit throttle let off and it would idle at 2000 rpm i couldnt even idle it down with the idle screw.Iwas way to lean,I know i have a carb just using that as a example.

2015 A/C Sport,With a few add ons..........
de3 is offline  
post #5 of 12 (permalink) Old 11-12-2012, 06:51 PM Thread Starter
Jounior Member
 
blowinsoot00's Avatar
 
Join Date: Jul 2012
Location: Goodyear Az
Posts: 250
 
im gonna pull the throttle body apart tomm, change the oil, and mess with the fuel controller. i know it sounds like it would be way lean but it smells super rich, almost eye watering...

09 xtx- custom fox 2.0 air shocks- bighorn tires- custom paint- 4 seat cage built by me- soft top- twisted stitch seats- half doors- intake built by me- magnaflow exhaust built by me- carillo 4 point harnesses all around- 5 h.i.d.'s- clutch kit- dynatek- no more turf saver...tig welded now- 2" wheel spacers- ss-212 rims in black-
blowinsoot00 is offline  
post #6 of 12 (permalink) Old 11-14-2012, 12:28 PM Thread Starter
Jounior Member
 
blowinsoot00's Avatar
 
Join Date: Jul 2012
Location: Goodyear Az
Posts: 250
 
ok i figured both my issues out. the headlights were coming on because i had a short at my taillight that was putting power to everything when the brake pedal was pushed. and as for the high idle i pulled the throttle body apart and cleaned all the sensors, but im pretty sure it was a blocked port in the ics solenoid, put everything back together and now its great. but i do still have the rev limiter in reverse in 2wd with the dynatek, does it only do away with it in 4wd?

09 xtx- custom fox 2.0 air shocks- bighorn tires- custom paint- 4 seat cage built by me- soft top- twisted stitch seats- half doors- intake built by me- magnaflow exhaust built by me- carillo 4 point harnesses all around- 5 h.i.d.'s- clutch kit- dynatek- no more turf saver...tig welded now- 2" wheel spacers- ss-212 rims in black-
blowinsoot00 is offline  
post #7 of 12 (permalink) Old 11-14-2012, 12:54 PM
Loyal Member
 
Joes5091's Avatar
 
Join Date: Apr 2009
Location: Waddell/Surprise. AZ
Posts: 2,681
 
On the High Idle try disconnect the battery for 15 min or so

2009 Prowler 700 XTX Walker Evans Shocks,STI Roctane 27/9/14 and 27/11/14 tires,Warn skid plates,Ridgid Ind Prerunner Cage,Home made spare tire carrier,Hids high and low beams,1.5 inch wheel spacers,E Brake Alarm, Rear diff vent mod Etc. NO TURF SAVER!
Joes5091 is offline  
post #8 of 12 (permalink) Old 11-14-2012, 03:20 PM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Thumbs up running good

DJ,glad you got your prowler tuned in,when i switched cdi boxes i still had rev limiter in reverse in two wheel drive.

2015 A/C Sport,With a few add ons..........
de3 is offline  
post #9 of 12 (permalink) Old 11-14-2012, 08:18 PM Thread Starter
Jounior Member
 
blowinsoot00's Avatar
 
Join Date: Jul 2012
Location: Goodyear Az
Posts: 250
 
sometimes when i start it it there is a rev limiter in high and low, but if i turn it off and restart all is well, just one of those quirks i guess.

09 xtx- custom fox 2.0 air shocks- bighorn tires- custom paint- 4 seat cage built by me- soft top- twisted stitch seats- half doors- intake built by me- magnaflow exhaust built by me- carillo 4 point harnesses all around- 5 h.i.d.'s- clutch kit- dynatek- no more turf saver...tig welded now- 2" wheel spacers- ss-212 rims in black-
blowinsoot00 is offline  
post #10 of 12 (permalink) Old 11-15-2012, 06:00 AM
Senior Member
 
Join Date: Jul 2012
Location: Bean Station, Tennessee
Posts: 412
 
That's crazy! I have the Dynatek CDI in my machine and I have no problems at all. Higher RPM's and no Rev Limiter in any scenario. You would think that yours being an ECU would be even better. Maybe I just got lucky (which would be a big change).

08 650xt
Big Bore Kit
Speedwerx Exhaust
1.5: Snorkels
Dyna FS Ignition
AMR Monster Coil
Highlifter 2in Lift
Highlifter 1in Wheelspacers
Custom Roll Cage
Trail Armor Doors
Intellitronix Oil, Temp, and Volt Gauges
RickTheRocket UHMW Bushings all around
Superwinch Terra 3500
Papa Slap Stage 3 Clutching with Fix Plate Mod
Daryle_TN is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67