Fuel tank sending unit problems - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler Electrical Discussions Arctic Cat Prowler electrical discussions.
Lighting, audio, GPS, communications, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-16-2008, 07:43 PM Thread Starter
Founding Member
 
Desertcat's Avatar
 
Join Date: Sep 2008
Location: Arizona
Posts: 3,867
 
Fuel tank sending unit problems

Hi guys, is any one having problems with there fuel tank level sending unit. My first problem started with it reading incorrect. I removed and cleaned and it worked fine for about two months. Now I have a second problem the float has a pin hole in it. The dealer only sells the complete assembly. Well off to the dealer I go I guess????



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
Desertcat is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-10-2009, 09:18 PM
Jounior Member
 
NEWTOTHIS's Avatar
 
Join Date: Jul 2009
Location: Maricopa, Az
Posts: 267
 
Bump I need this problem solved as well. It isn't reading the fuel level
NEWTOTHIS is offline  
post #3 of 5 (permalink) Old 08-10-2009, 09:24 PM Thread Starter
Founding Member
 
Desertcat's Avatar
 
Join Date: Sep 2008
Location: Arizona
Posts: 3,867
 
Quote:
Originally Posted by NEWTOTHIS View Post
Bump I need this problem solved as well. It isn't reading the fuel level
Remove your sender and with a DMM check the sensor sweap. Turn your meter to Ohms and put the red lead on one wire and the black lead on the other wire at the connector. Move the float arm from full to empty, it should change nice and smooth, no dead spots.

I had to clean mine and it works great. Once I did find a pin hole in the float but the main problem was the contacts.


Hope this helps
Seth



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

SETH
TEAM PROWLER NATION
Desertcat is offline  
 
post #4 of 5 (permalink) Old 08-10-2009, 09:33 PM
Jounior Member
 
NEWTOTHIS's Avatar
 
Join Date: Jul 2009
Location: Maricopa, Az
Posts: 267
 
Sweet thanks for all the help
NEWTOTHIS is offline  
post #5 of 5 (permalink) Old 08-10-2009, 09:54 PM
Loyal Member
 
sandchris's Avatar
 
Join Date: Oct 2008
Location: PEORIA,AZ
Posts: 3,564
 
sandchris is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73