4800 rpm's is all she'll do - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 36 (permalink) Old 01-14-2010, 07:09 PM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
Question 4800 rpm's is all she'll do

Yep , got it out today. Was checking the smoking belt thing and found out it wont rev anymore than 4800 in any gear. I posted a rev limiter thread and got no answers.So what do you guys think of this. Low , high, forward reverse,4 wheel, two wheel, all she will do! Has to be something electrical but what?
prowlerbob is offline  
Sponsored Links
Advertisement
 
post #2 of 36 (permalink) Old 01-14-2010, 07:19 PM
Senior Member
 
soazcat's Avatar
 
Join Date: Oct 2009
Location: Willcox Az
Posts: 491
 
Quote:
Originally Posted by prowlerbob View Post
Yep , got it out today. Was checking the smoking belt thing and found out it wont rev anymore than 4800 in any gear. I posted a rev limiter thread and got no answers.So what do you guys think of this. Low , high, forward reverse,4 wheel, two wheel, all she will do! Has to be something electrical but what?


Does your dash read H-L-R-N when you shift ? im pretty sure 4800 is all they will turn in neutral . maybe the switch is stuck telling the ecm your in neutral ? im not for sure ........
soazcat is offline  
post #3 of 36 (permalink) Old 01-14-2010, 07:51 PM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
I don't think that it was. Where is the switch located so i can check it.
prowlerbob is offline  
 
post #4 of 36 (permalink) Old 01-14-2010, 07:59 PM
Senior Member
 
soazcat's Avatar
 
Join Date: Oct 2009
Location: Willcox Az
Posts: 491
 
Quote:
Originally Posted by prowlerbob View Post
I don't think that it was. Where is the switch located so i can check it.

i just walked out an looked at my xtz and shifter postion switch is down onthe side of the trans under the drivers seat . see if its unplugged or if it is even showing the gear postion on the dash .
soazcat is offline  
post #5 of 36 (permalink) Old 01-14-2010, 08:06 PM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
Was justtalking to my son on phone and he looked at it today. We don't think it was showing gear, and he said the reverse override switch was not working at all today. So maybe one of the switches is stuck . Thanks , i will check in morning.
prowlerbob is offline  
post #6 of 36 (permalink) Old 01-14-2010, 09:05 PM
Senior Member
 
ProwlerFan74's Avatar
 
Join Date: Dec 2009
Location: Tampa Area FL
Posts: 389
 
weird...
hope you find the culprit

2009 Arctic Cat Prowler XTZ1000

GAMERS check out my Gaming Channel WhatsMyGame https://www.youtube.com/user/rcevolution74
ProwlerFan74 is offline  
post #7 of 36 (permalink) Old 01-16-2010, 03:30 PM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
ok Soazcat, We checked thedash to see if hte gear indicator worked. It works in r,n d, but when in low range and "E" comes up where the L should be.We checked the switch on the trans. , unhooked and replaced didn't seem to be a problem. Didn't have ohm meter so couldnt check switch, will do that tomorow.Do you guys think the switch is bad and not letting the reverse rev limiter from disengaging or what? Still won't rev over 4800.
prowlerbob is offline  
post #8 of 36 (permalink) Old 01-16-2010, 03:31 PM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
Also, it shifts into all gears smoothly, so i don't think it is linkage.
prowlerbob is offline  
post #9 of 36 (permalink) Old 01-17-2010, 09:44 AM
Senior Member
 
soazcat's Avatar
 
Join Date: Oct 2009
Location: Willcox Az
Posts: 491
 
Quote:
Originally Posted by prowlerbob View Post
Also, it shifts into all gears smoothly, so i don't think it is linkage.

well BOB i would say there is a problem with the shifter postion switch , but im not 100% on it i did start mine and yep 4800 is all itll do in neutral . i would call eaac or one of the other supporting dealers on here and ask them if they have seen this . sorry im not more help just havnt worked on these Cats enough yet . good luckand let us know what ya find
soazcat is offline  
post #10 of 36 (permalink) Old 01-17-2010, 10:23 AM Thread Starter
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
Thanks , I tend to agree with you about the switch, what baffles me is the indicator on dash reads E when the car is in low range.
prowlerbob is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58