E is on in the digital dash - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-24-2010, 09:48 AM Thread Starter
Junior Member
 
mantisman23's Avatar
 
Join Date: Feb 2010
Location: Nyssa Oregon
Posts: 22
 
E is on in the digital dash

I just got me a 08 prowler and where it will say N or H it has a E sometimes what is that i can't seem to find anything out in the service manual? Thanks
mantisman23 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-24-2010, 10:00 AM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Quote:
Originally Posted by mantisman23 View Post
I just got me a 08 prowler and where it will say N or H it has a E sometimes what is that i can't seem to find anything out in the service manual? Thanks
Welcome to the forum and congrats on your new ride.

I think the E that you are seeing means Error. I have seen this on my XTZ when it doesn't find a gear.

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
post #3 of 6 (permalink) Old 02-24-2010, 10:38 AM
Rides all the time
 
Mustanggeek's Avatar
 
Join Date: Nov 2008
Location: Phoenix, AZ
Posts: 1,510
 
Welcome to the site. I believe flying121 is correct.
Mustanggeek is offline  
 
post #4 of 6 (permalink) Old 02-24-2010, 10:39 AM Thread Starter
Junior Member
 
mantisman23's Avatar
 
Join Date: Feb 2010
Location: Nyssa Oregon
Posts: 22
 
thanks. So it must need the linkage adjusted a little
mantisman23 is offline  
post #5 of 6 (permalink) Old 02-24-2010, 11:25 AM
Rides all the time
 
Mustanggeek's Avatar
 
Join Date: Nov 2008
Location: Phoenix, AZ
Posts: 1,510
 
I had to adjust mine after a first got it. Once adjusted I haven't had to mess with it since.
Mustanggeek is offline  
post #6 of 6 (permalink) Old 02-24-2010, 05:33 PM
Lifetime Member
 
GlamisProwler's Avatar
 
Join Date: Sep 2008
Location: Oc
Posts: 1,603
 
It may do this when it over heats also, Mine was flashing red also

http://utvweekly.com/index.php/2009/11/ricks-arctic-cat-prowler-1000/
GlamisProwler is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73