Need help finding someone to work on 06 650 H1 - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 5Likes
  • 1 Post By de3
  • 1 Post By mlh1962
  • 1 Post By Fairmont79
  • 1 Post By de3
  • 1 Post By Bryan
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-13-2015, 10:33 AM Thread Starter
Junior Member
 
Join Date: Aug 2015
Location: Chesterfield, South Carolina
Posts: 4
 
Need help finding someone to work on 06 650 H1

Need help finding a repair shop to work on my 650 H1 prowler. I am located in Chesterfield, SC 29709. 60 miles east of Charlotte, NC and 40 miles west of Rockingham, NC
After reading different threads on this sight I feel the repairs needed are beyond what I can do.
The closes Artic Cat dealer is 80 miles away from me. I have been to several ATV/UTV dealers and they say they don't work on Artic Cats.
After reading I think it is in need of clutch and belt issues.
Thank you any help. Hope someone knows were I can take it. Hunting season is comming closer and need it get it fixed.
jd3rdnoah is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-13-2015, 12:51 PM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Quote:
Originally Posted by jd3rdnoah View Post
Need help finding a repair shop to work on my 650 H1 prowler. I am located in Chesterfield, SC 29709. 60 miles east of Charlotte, NC and 40 miles west of Rockingham, NC
After reading different threads on this sight I feel the repairs needed are beyond what I can do.
The closes Artic Cat dealer is 80 miles away from me. I have been to several ATV/UTV dealers and they say they don't work on Artic Cats.
After reading I think it is in need of clutch and belt issues.
Thank you any help. Hope someone knows were I can take it. Hunting season is comming closer and need it get it fixed.

What kind of problems are you having.........
jd3rdnoah likes this.

2015 A/C Sport,With a few add ons..........
de3 is offline  
post #3 of 7 (permalink) Old 08-13-2015, 07:59 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Location: Chesterfield, South Carolina
Posts: 4
 
It appears the clutck is stuck in engaged. It will not idle in gear. You can't change gears without turning it off. If you start it in netural you have to cram it in gear and be ready to go.
jd3rdnoah is offline  
 
post #4 of 7 (permalink) Old 08-13-2015, 09:14 PM
Lifetime Member
 
mlh1962's Avatar
 
Join Date: Jul 2011
Location: Lexington, Missouri
Posts: 3,621
 
Garage
Quote:
Originally Posted by jd3rdnoah View Post
It appears the clutck is stuck in engaged. It will not idle in gear. You can't change gears without turning it off. If you start it in netural you have to cram it in gear and be ready to go.
How high are your RPM's at idle? If it's too high it will cause that problem, I think it should be around 1,250 rpm's
jd3rdnoah likes this.

'07 Prowler 650 H1 XT, L.E.D. stop/turn signals, Summit Racing heater, AC winch, AC windshield, soft cab & doors, 6' Eagle Plow, oil gauge, Maxxis MT-762 truck tires, AC Fender Flares, E-Brake alarm, Yutrax UTV Jump Seat, Dynatek CDI
Missouri Mike
mlh1962 is offline  
post #5 of 7 (permalink) Old 08-14-2015, 02:57 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,109
 
Sounds like your wet clutch is engaging to soon. Maybe a broken spring on it? Idle too high, wet clutch issue will both cause tension on the trans making shifting difficult. Wet clutch should not engage until approx. 1800 rpm.
jd3rdnoah likes this.

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #6 of 7 (permalink) Old 08-14-2015, 09:05 AM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Maybe the one way bearing.......on the wet clutch
jd3rdnoah likes this.

2015 A/C Sport,With a few add ons..........
de3 is offline  
post #7 of 7 (permalink) Old 08-14-2015, 09:14 AM
Moderator
 
Bryan's Avatar
 
Join Date: Dec 2014
Location: Eastern most Iowa
Posts: 1,015
 
Quote:
Originally Posted by mlh1962 View Post
How high are your RPM's at idle? If it's too high it will cause that problem, I think it should be around 1,250 rpm's
Thats what was causing mine to bind up. After installing the K&N pre-filter and cleaning and re-oiling the main filter, mine did exactly the same thing when I drove it afterwards. I had to reset the idle, 1250 rpm's and it cured the shifting problem.
jd3rdnoah likes this.

'09 650XT H1, 72" Eagle Plow, Warn 3500 Winch. Dyna CDI box, UNI filters, A/C V-bag and console, EPI lift kit, Highlifter springs, Scat ProCar suspension seats. Rick the Rockets A frame and shock bushings. 28x12X14 Raceline Bruisers on Vision rims, on all corners. Cowling heat vents. Factory heat and defrost. RD's custom alternator kit. XTZ hood scoop and front shocks. Monster shock covers, turn signals. OEM glass sport windshield, sliding rear window, and lights, lights and more lights!
Bryan is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73