max rpm - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-09-2010, 06:33 AM Thread Starter
Jounior Member
 
moose's Avatar
 
Join Date: Mar 2009
Posts: 155
 
max rpm

hey guys, was wondering if my 09 XTX should get higher rpm's than 5,500?? it's all stock right now and don't have my rear seats in at the moment. it don't matter if i have traction or not, 2 or 4 wheel drive on, high, low, it won't get any higher than 5 500. might be normal, was just wondering. cause when in sand pits seems like it would need a lil more RPM's.
thanks all.
moose is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-09-2010, 08:47 AM
Jounior Member
 
Join Date: Dec 2009
Location: central mississippi 39180
Posts: 271
 
yes you should be able to rev higher than that. put it in neutral and rev it up and see what it tachs up to.
- sounds like something is not right. 5500 is WAY too low and is nowhere near the rev limiter.

///AIRDAM clutch machining
< http://airdamclutches.com/ >
///AIRDAM is offline  
post #3 of 9 (permalink) Old 03-09-2010, 08:50 AM
Senior Member
 
soazcat's Avatar
 
Join Date: Oct 2009
Location: Willcox Az
Posts: 491
 
Quote:
Originally Posted by ///AIRDAM View Post
yes you should be able to rev higher than that. put it in neutral and rev it up and see what it tachs up to.
- sounds like something is not right. 5500 is WAY too low and is nowhere near the rev limiter.

ADAM that wont work , in neutral the engine will only hit 4800rpm . it needs to be in gear to turn higher .
soazcat is offline  
 
post #4 of 9 (permalink) Old 03-09-2010, 09:20 AM Thread Starter
Jounior Member
 
moose's Avatar
 
Join Date: Mar 2009
Posts: 155
 
i thought that was low but wasn't sure. could a worn belt be the cause or bad stator? since day one when the fan kicks on my headlights go dim, told the shop about this when i last brought it in but i highly doubt they tested the stator or even bothered with it.. what else could be the cause? i'm at 1800 miles. bad clutch maybe, i once got mud and water in the clutch, but brought it at the shop for cleaning, so if wasn't done right then they should replace it, i still have 4 years warranty.
moose is offline  
post #5 of 9 (permalink) Old 03-09-2010, 12:24 PM
Junior Member
 
Join Date: Feb 2010
Posts: 8
 
Check factory speck for peak Hp my xtz 1000 is at 6800
SandHopper is offline  
post #6 of 9 (permalink) Old 03-09-2010, 12:47 PM
Jounior Member
 
Join Date: Dec 2009
Location: central mississippi 39180
Posts: 271
 
the 650s and 700s is something like 6500RPM so 5500 is a taste low.

i did not know that it would only do 4500 in neutral thats my bad.

a worn out belt will not change your RPMs, it will decrease your top speed, and allow the clutches to slip, but will not effect your RPM. your bike should still rev and hit the rev limiter in low and high range. i dont see where a worn out clutch sheave would do anything like that either. worn out clutches do not effect the rev either. if you are not rev'ing all the way up to the rev limiter i'd check the plug, fuel system, and check for codes. seems something electrical or fuel related.

///AIRDAM clutch machining
< http://airdamclutches.com/ >
///AIRDAM is offline  
post #7 of 9 (permalink) Old 03-09-2010, 01:51 PM
Jounior Member
 
Bipolar Jim's Avatar
 
Join Date: Nov 2008
Location: Yacolt, Washington
Posts: 105
 
6500 to 6800 is the range your looking for, what altitude are you running at. how many miles are your XTZ
Bipolar Jim is offline  
post #8 of 9 (permalink) Old 03-09-2010, 01:57 PM Thread Starter
Jounior Member
 
moose's Avatar
 
Join Date: Mar 2009
Posts: 155
 
it's a XTX700, 1800 miles...i'm below 2000ft i recal
moose is offline  
post #9 of 9 (permalink) Old 03-09-2010, 05:24 PM Thread Starter
Jounior Member
 
moose's Avatar
 
Join Date: Mar 2009
Posts: 155
 
so could it be the stator??
thanks again fellas. i guess i'm due for another trip at the cat shop! haha.
moose is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58