Rod Knock - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 04-09-2010, 07:16 PM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location: Tanana, Alaska
Posts: 23
 
Rod Knock

I've got a new Prowler 1000 with about 300 miles on it. I've got a knock in the engine. Sounds like a rod. The typical knock-knock between acceleration and decceleration throttle position. Is this a chronic problem with this engine? Can the crank be pressed apart and just replace the rod and bearing? Is it hard to shove one of these engines up somebody's azz?
Alaskajohn is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 04-09-2010, 07:24 PM
Senior Member
 
soazcat's Avatar
 
Join Date: Oct 2009
Location: Willcox Az
Posts: 491
 
hmmmmmm rod knock? well i think youre the first one on here to have that problem ! did you buy it new or used ? what happened to cause the knock ? are you sure there isnt anything loose in the clutch? im just asking because as far as i know these motors are pretty damn tough.
soazcat is offline  
post #3 of 19 (permalink) Old 04-09-2010, 07:58 PM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location: Tanana, Alaska
Posts: 23
 
I bought it new a couple weeks ago. I didn't buy the warranty, so I guess I'm screwed.

It sure sounds like a definite rod knock. I used a stethescope and the noise seems to be coming from the crankcase, not the from the clutch. I'm going to dump the oil tomorrow and see what I find. I see the crank is a pressed pin type. I've rebuilt a few hundred of those when I had my Yamaha dealership. It seems that Arctic Cat only sells the complete crank. Anyone know this for sure? If I could get a rod and bearing, it would be an easy fix.
Alaskajohn is offline  
 
post #4 of 19 (permalink) Old 04-09-2010, 08:12 PM
Senior Member
 
soazcat's Avatar
 
Join Date: Oct 2009
Location: Willcox Az
Posts: 491
 
oh yea now i remember . did you ride it all the way back home? if its only a couple of weeks old all new cats come with a mfg 6 month warranty i beleive . its the extended one you have to pay for . as for how it goes together on the crank i dont know . some one will chime in !
soazcat is offline  
post #5 of 19 (permalink) Old 04-10-2010, 05:49 AM
Jounior Member
 
scheftie's Avatar
 
Join Date: Feb 2010
Location: GODS COUNTRY LANGDON ND
Posts: 157
 
Rod knock

I had a 650 that ran fine for 200 hours with wheels on it only made 50 more hours once I put tracks on. I beleive you have tracks also,correct? I had change oil often. within 50 of the failure. Often wondered if sucking in snow could have contributed to this. Or if moisture had stuck the relief valve for the oil pump. Anyway went back together with an oil pressure gauge for next time. Made mine into a 700 but also had to buy a crank. See if there is room for two of them up there!
scheftie is offline  
post #6 of 19 (permalink) Old 04-10-2010, 07:05 AM
Senior Member
 
Join Date: Jun 2009
Location: N.E. Ohio
Posts: 463
 
Wow this is the first I've heard of a rod nocking. Call your dealer and see if he has a big azz maybe it will fit. Lol. I hope you get it fixed.
cat n hat is offline  
post #7 of 19 (permalink) Old 04-10-2010, 10:05 AM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location: Tanana, Alaska
Posts: 23
 
Quote:
Originally Posted by scheftie View Post
I had a 650 that ran fine for 200 hours with wheels on it only made 50 more hours once I put tracks on. I beleive you have tracks also,correct? I had change oil often. within 50 of the failure. Often wondered if sucking in snow could have contributed to this. Or if moisture had stuck the relief valve for the oil pump. Anyway went back together with an oil pressure gauge for next time. Made mine into a 700 but also had to buy a crank. See if there is room for two of them up there!

I was on tracks. Not running fast. Took me about 10 hours to run the 120 miles down and about 7 on the way back. I picked up the knock about 10 miles from town on the way back. Didn't notice anything showing a lack of oil pressure. It seems if the rod was out, I'd have zip for oil pressure unless this crank isn't pump fed. That would be hard to believe. I think the speedo is supposed to go nuts if there is a oil pressure problem. I did notice mine would quit once in awhile, but would come back up when I hit a bump. The tach always worked fine.

I'm with ya brother on the oil pressure guage.
Alaskajohn is offline  
post #8 of 19 (permalink) Old 04-10-2010, 10:13 AM
Jounior Member
 
Join Date: Dec 2008
Posts: 294
 
All arcitc cat come standard with the 6month warranty, So I would take it to your dealer and see it they will fix it, this is the first one I've ever heard of any knocking.
eaac is offline  
post #9 of 19 (permalink) Old 04-11-2010, 07:58 AM
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
sounds like a good time to see what AC is worth.
prowlerbob is offline  
post #10 of 19 (permalink) Old 04-11-2010, 10:59 AM
Jounior Member
 
Join Date: Apr 2009
Posts: 192
 
Run it like ya stole it!! its still under factory warranty if there is a problem it will show itself. then ya get all new parts.
Hollon is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73