My kitty has no power.. - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-11-2010, 09:02 PM Thread Starter
Jounior Member
 
Dnspream's Avatar
 
Join Date: Feb 2010
Location: Little Canada ,MN
Posts: 199
 
My kitty has no power..

Finally got a chance to get the prowler up to the lake for the first time since i bought it. bought it used with only 127 miles on it, its a 07 650H1 XT. I took her down the dirt road and seemed to get to 30 MPH pretty quick but fell on her face after that. I was running about 45MPH along side my honda rubicon 500 and then put it to the floor and the cat just couldnt go any more, yet the rubicon just snorked and flew by..Also when taking off from a dead stop when i floor it (2wd) it will spin the tires for a little bit(2ft) then stop spinning and gain speed slowly.
Now i would think this machine should have more than this.
Now dont get me wrong, i LOVE this machine it was awesome to drive in the places i did and i had a blast, I just think it should have more snork than what it showed me this weekend..
Any ideas guys? Could it be my clutch, air filter,some thing hanging up??
OH, I also heard a clanking noise when i let off the throttle, almos like the rollers in the clutch were sticking then releasing rapidly.. Please help!

The UP side, is i figured out how to adjust my shifter, so now that workes good.
Dnspream is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-12-2010, 03:41 AM
Senior Member
 
Triple J's Avatar
 
Join Date: Jan 2010
Location: Minnesota
Posts: 618
 
Around 48 is top speed stock, need different CDI box to change limiter.

Clutchiing will help off the line, you've got to remember these things weigh over twice what the atv's run.

2010 Prowler XTZ 1000-
27" Grim Reaper Tires/Home Made Roof/Arctic Cat Mirror/Quadboss Folding Windshield w/ home made support bar/LED Tail-Brake lights//Venom 4000 lb Winch/Amsteel synthetic line/Home Made Doors/Custom Adjustable Seats/Custom Oh Crap bar for passenger/Tonneau Cover/Fat Max storage Box in bed
Tiger Tail Towing system
Triple J is offline  
post #3 of 10 (permalink) Old 04-12-2010, 07:45 AM
Senior Member
 
prowlerbob's Avatar
 
Join Date: Dec 2008
Location: southern Illinois
Posts: 682
 
is it revving up like normal,or seem to be held back by something? Could be dirty air filter,but with only 127 miles i would think something mechanical.If it is reviing normal check and be sure it is not in low range,with you adjusting shifter.
prowlerbob is offline  
 
post #4 of 10 (permalink) Old 04-12-2010, 08:38 AM Thread Starter
Jounior Member
 
Dnspream's Avatar
 
Join Date: Feb 2010
Location: Little Canada ,MN
Posts: 199
 
Its definatly not in low, But when i gas it at 45 you can hear the motor want to go but its like the clutch wont back shift or something.
I can get it up to around 55 (acording to the spedo) when on flat -to down hill angles, but takes a very long time..
And shouldent the low end be more than this? I can only spin the tires for 2 feet in very dry dirt, or gravel road..
Please help I'm sure this aint right!!!!!
Dnspream is offline  
post #5 of 10 (permalink) Old 04-12-2010, 09:46 AM
Jounior Member
 
moose's Avatar
 
Join Date: Mar 2009
Posts: 155
 
keep in mind, like mentioned above..these things are allot heavier than a ATV, you wont get the speeds you would on a 650 ATV !! i have a 09 XTX 700, i think my max speed is 60, maybe 65 TOPS. i'm sure someone with a xt 650 will jump in the thread...
moose is offline  
post #6 of 10 (permalink) Old 04-12-2010, 09:46 AM
Junior Member
 
Join Date: May 2009
Posts: 19
 
Sounds right to me for a 650 i wish i could hit 55 mph u must have a cdi and its not back shifting its cuting out spark
lars is offline  
post #7 of 10 (permalink) Old 04-12-2010, 10:34 AM
Junior Member
 
Jake's Avatar
 
Join Date: Aug 2009
Location: South Dakota
Posts: 21
 
My 08 xt will pull hard up until the limiter kicks in at 50 mph, check the belt to see if it has been burned before you got it, or if the seal has leaked oil onto the belt causing it to slip.
Jake is offline  
post #8 of 10 (permalink) Old 04-12-2010, 05:26 PM Thread Starter
Jounior Member
 
Dnspream's Avatar
 
Join Date: Feb 2010
Location: Little Canada ,MN
Posts: 199
 
Quote:
Originally Posted by Jake View Post
My 08 xt will pull hard up until the limiter kicks in at 50 mph, check the belt to see if it has been burned before you got it, or if the seal has leaked oil onto the belt causing it to slip.
OK i will see. It does make a wierd sound when slowing down, Like a metal to metal clanking sound, Almost like the rollers are sticking in the clutch, Or is that a part of the engine braking doing that??

PS I dont think it has an after market rev limiter on it, but doesent even sound like the motor is cutting out, just seems under powered.

I wish there was somebody around here with the same machine i have, so i could try thiers, just doesent seem right to me. And by the way the rubicon is just a 500 with 3000 miles on it and all stock..

Other than all this I LOVE this machine..
Dnspream is offline  
post #9 of 10 (permalink) Old 04-12-2010, 05:39 PM
Senior Member
 
RyansCat's Avatar
 
Join Date: Mar 2009
Location: London Ky
Posts: 583
 
Quote:
Originally Posted by Dnspream View Post
OK i will see. It does make a wierd sound when slowing down, Like a metal to metal clanking sound, Almost like the rollers are sticking in the clutch, Or is that a part of the engine braking doing that??

PS I dont think it has an after market rev limiter on it, but doesent even sound like the motor is cutting out, just seems under powered.

I wish there was somebody around here with the same machine i have, so i could try thiers, just doesent seem right to me. And by the way the rubicon is just a 500 with 3000 miles on it and all stock..

Other than all this I LOVE this machine..
I rode with 3 honda 500's last summer. From a standstill they would just slightly pull away but from midrange and top speed they couldn't outrun me. Just takes the big girl awhile to build steam. I pulled the 3wd hondas out of several holes that day.
I have an rm stator cdi on my 650.
RyansCat is offline  
post #10 of 10 (permalink) Old 04-12-2010, 06:43 PM Thread Starter
Jounior Member
 
Dnspream's Avatar
 
Join Date: Feb 2010
Location: Little Canada ,MN
Posts: 199
 
Quote:
Originally Posted by RyansCat View Post
I rode with 3 honda 500's last summer. From a standstill they would just slightly pull away but from midrange and top speed they couldn't outrun me. Just takes the big girl awhile to build steam. I pulled the 3wd hondas out of several holes that day.
I have an rm stator cdi on my 650.
YEA my 500 isnt very good in mud ether, But it sure is a good work horse.
Dnspream is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58