2009 prowler XTZ power issues - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 51 (permalink) Old 06-06-2016, 08:49 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 77
 
2009 prowler XTZ power issues

Hello new to the forum. I have posted about a prowler XTZ I just bought on another forum, but it seems here may be a better place to learn about it since it's for prowlers. I'll go ahead and post a link so I don't have to type an essay and y'all will know what has been discussed. Thanks!

Http://www.arcticchat.com/forum/gene...er-issues.html
QuadraDuraBurb is offline  
Sponsored Links
Advertisement
 
post #2 of 51 (permalink) Old 06-06-2016, 04:43 PM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,126
 
Welcome to the forum! Yes, this is the best place to be! We have great members, and the site stays very active!
Followed your link,
Arctic cat prowler power issues




2009 arctic cat prowler 1000. Well I gotta ask now. This mfer ran really strong when I test drove and bought it and drove a bit. Well it started smelling hot, so I did a bit of troubleshooting and found out the coolant is low. So I opened it up and did some major burping to the system.

Finally I put the cap back on and went for a ride. Now no power hardly at all. What should I check for? Is a belt gone? Clutch? Sounds like it's bogging like the power would be going somewhere and it can't be the brakes because it rolls to a stop.

I've already pulled both injectors and watched them spray. They look good. Pulled a sensor (IAT?) On the intake and cleaned it.

I'll also add in reverse or low before and barely tapping on the accelerator you would get thrown around with power. Now not so much. Thanks!

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD

Last edited by Fairmont79; 06-06-2016 at 04:49 PM.
Fairmont79 is offline  
post #3 of 51 (permalink) Old 06-06-2016, 04:50 PM
Lifetime Member
 
mlh1962's Avatar
 
Join Date: Jul 2011
Location: Lexington, Missouri
Posts: 3,625
 
Garage
Welcome to the site! I read the other post and hope someone here can help, I just have the old 650 carb model but there are several XTZ owners here that may have some ideas.

'07 Prowler 650 H1 XT, L.E.D. stop/turn signals, Summit Racing heater, AC winch, AC windshield, soft cab & doors, 6' Eagle Plow, oil gauge, Maxxis MT-762 truck tires, AC Fender Flares, E-Brake alarm, Yutrax UTV Jump Seat, Dynatek CDI
Missouri Mike
mlh1962 is offline  
 
post #4 of 51 (permalink) Old 06-07-2016, 03:26 AM
Senior Member
 
Diesel Racer's Avatar
 
Join Date: Dec 2010
Location: NH
Posts: 799
 
I had a spark plug poop out on mine and it did the same thing for no reason.



Tim

2010 A/C XTZ with some "Stuff" SOLD
But still here everyday to contribute to the cause
Diesel Racer is offline  
post #5 of 51 (permalink) Old 06-07-2016, 04:15 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,126
 
I had one fail also. I now carry a spare! They just screw on the wire.

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #6 of 51 (permalink) Old 06-07-2016, 04:40 AM
Senior Member
 
Retired1's Avatar
 
Join Date: Aug 2009
Location: Woodward County, Oklahoma
Posts: 413
 
My 2009 XTZ 1000 loses power, unexpectedly, about once a year. A new set of plugs restores the power and response immediately. I have never had any other issues with it's performance.

Terry
2009 Prowler XTZ 1000 Baja - ITP beadlock wheels, ITP Baja Cross X/D tires, 2" wheel spacers, harness bar, 5 point harnesses, custom doors, 4 Vision X LED lights, 2 PIAA lights, RAM mounts on roll bar and dash, military truck mirrors, polished aluminum rear frame brace, inside tube rear frame stiffeners, Mossy Oak camo pattern seats, custom front brush guard, parking brake 'on' alarm, Throttlemaxx controller, Uni pre-filter, and Mobil 1 4T M/C 10W-40 racing oil with K&N filter.
Retired1 is offline  
post #7 of 51 (permalink) Old 06-07-2016, 08:32 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,126
 
Great to gain some knowledge on the 1000's! I'm still learning that beast! Thanks to all!

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #8 of 51 (permalink) Old 06-07-2016, 09:18 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 77
 
Thanks guys! I actually just think I figured out I actually have a wire issue. Supposed to have a guy pick up new fluids, plugs, and wires for me and I'm going to change them out when I get home. Dang I should have found this forum first!
QuadraDuraBurb is offline  
post #9 of 51 (permalink) Old 06-07-2016, 09:27 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 77
 
Looks like I'll need a water pump also. Weep hole on the driver side is leaking. Actually almost seems like oil though. I'll be doing some more investigating on that and taking pictures.
QuadraDuraBurb is offline  
post #10 of 51 (permalink) Old 06-07-2016, 11:05 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,126
 
Glad you are moving ahead on your Prowler! I can't remember on my water pump if there is a seal behind it or not, but I think there is! The water pump drive comes through the casting behind the pump. From the diagram, all I saw was a 99 cent O-Ring!

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73