Prowler 1000 XTZ won't start - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-16-2017, 11:23 AM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 9
 
Prowler 1000 XTZ won't start

I'm having problems with my 2009 atz 1000 prowler. long story was running fine for 3 days ( new machine for me) let off gas and died will not start up ( sounds like it wants to start ) found that the fuel pump was low on pressure and replaced the pump. now have 42 lbs of pressure. still wont start same issue and sound ( I have no codes) was told to test the rollover sensor and that is good. found some small cooper flakes in gas tank under fuel pump so thought maybe got in injectors as they had week spray so replaced the injectors and still same issue no codes. If I take off not unplug mass flow sensor and put finger on hole to stop vacuum pressure it will Idle and that's it. If I unplug mass flow sensor I get a code. if I unplug throttle position sensor I get a code

I have no dealer close to me that has diagnostic tools to check all the sensors or ecu
Where should I go from here
MontyC is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-18-2017, 02:30 AM
Senior Member
 
Diesel Racer's Avatar
 
Join Date: Dec 2010
Location: NH
Posts: 798
 
Did you change your fuel filter?, how is your main and pre-air filters ?



Tim

2010 A/C XTZ with some "Stuff" SOLD
But still here everyday to contribute to the cause
Diesel Racer is offline  
post #3 of 6 (permalink) Old 08-18-2017, 10:34 AM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 9
 
all filters are new and have 42 lbs pressure after fuel filter. The shop thinks it could be a sensor or maybe a ecu but that's a lot of maybes. It will idle if I take off the mass flow sensor and cover the hole but that's it
MontyC is offline  
 
post #4 of 6 (permalink) Old 08-19-2017, 04:33 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,103
 
Most of the resources I've talked to tend to rule out ECU,s as a part that fails, but they do! The sensor you mention, is that the one mounted to the air box?

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #5 of 6 (permalink) Old 08-20-2017, 10:55 AM Thread Starter
New Member
 
Join Date: Jun 2017
Posts: 9
 
well I broke down and took it to a dealer. It was in a local shop for 2 months. the dealer called me in 2 hrs and said it was the fuel pressure regulator. With new pump installed but did not replace regulator at old shop. pressure would build up to 42 lbs but would drop off and not hold the pressure and regulator would not tell pump to start again to keep pressure. So did not need all the diff parts that was put in. thanks for everyone's help on this issue
MontyC is offline  
post #6 of 6 (permalink) Old 08-20-2017, 03:20 PM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,103
 
Glad you got in running! Getting harder to find shops that know WTF they are doing! To many parts changers!

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73