Mixture Control - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-15-2019, 12:19 PM Thread Starter
New Member
 
Join Date: Sep 2019
Location: Pinetop, Az
Posts: 3
 
Mixture Control

Hi, new guy here. Just bought a '09 700 XTX, drove it home, by the time I got home my eyes were watering from it running really rich. Wife was following me and said it really smelled. From what I can find out is that these have an ECM controlling the engine. Since I cannot find an O2 sensor I presume that they run in open loop. Can someone enlighten me on this, I really would like to get this fixed. Off to the garage to pull the plug.
Thanks
waho is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-15-2019, 04:36 PM
Moderator
 
Bryan's Avatar
 
Join Date: Dec 2014
Location: Eastern most Iowa
Posts: 1,017
 
Black smoke from the tailpipe? MAP or Air temp sensor possibly?

'09 650XT H1, 72" Eagle Plow, Warn 3500 Winch. Dyna CDI box, UNI filters, A/C V-bag and console, EPI lift kit, Highlifter springs, Scat ProCar suspension seats. Rick the Rockets A frame and shock bushings. 28x12X14 Raceline Bruisers on Vision rims, on all corners. Cowling heat vents. Factory heat and defrost. RD's custom alternator kit. XTZ hood scoop and front shocks. Monster shock covers, turn signals. OEM glass sport windshield, sliding rear window, and lights, lights and more lights!
Bryan is offline  
post #3 of 5 (permalink) Old 09-16-2019, 09:11 AM Thread Starter
New Member
 
Join Date: Sep 2019
Location: Pinetop, Az
Posts: 3
 
No smoke, pulled the plug and it was dry and dark brown which to me means a bit rich.
waho is offline  
 
post #4 of 5 (permalink) Old 09-16-2019, 11:24 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,111
 
Quote:
Originally Posted by waho View Post
Hi, new guy here. Just bought a '09 700 XTX, drove it home, by the time I got home my eyes were watering from it running really rich. Wife was following me and said it really smelled. From what I can find out is that these have an ECM controlling the engine. Since I cannot find an O2 sensor I presume that they run in open loop. Can someone enlighten me on this, I really would like to get this fixed. Off to the garage to pull the plug.
Thanks
You can download a free service manual at Country Cat, I have the same machine.

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #5 of 5 (permalink) Old 09-16-2019, 10:47 PM Thread Starter
New Member
 
Join Date: Sep 2019
Location: Pinetop, Az
Posts: 3
 
I've got a CD from TechSpark, its a little skimpy on the throttle body. Will check with CC.
Thanks
waho is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58