Broke belt on XTZ 1000! - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-05-2010, 09:37 PM Thread Starter
Junior Member
 
billemartin's Avatar
 
Join Date: Jan 2010
Posts: 14
 
Broke belt on XTZ 1000!

Anybody have their belt break? Looks like it slung the weights out of the clutch too...only have 240 miles on it. Any ideas or suggestions?
billemartin is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-05-2010, 10:08 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Quote:
Originally Posted by billemartin View Post
Anybody have their belt break? Looks like it slung the weights out of the clutch too...only have 240 miles on it. Any ideas or suggestions?
Do you ride in a lot of mud? Sounds like some serious heat built up in there while the belt was slipping and then it let go. The rollers most likely got so hot the peeled the covers off of the metal inner and burned flat spots into the fixed plate. I had this happen.

Call Adam from Airdam Clutches he is the man when it comes to the CVT clutches and belts. You will be very happy with his work and will not have any future problems once he does his magic.

/// Airdam - Home

Good luck and let us know what you end up with.

Last edited by flying121; 09-06-2010 at 11:38 AM.
flying121 is offline  
post #3 of 5 (permalink) Old 09-06-2010, 11:10 AM
Senior Member
 
sandy4bama's Avatar
 
Join Date: Mar 2010
Location: Pell City, Al.
Posts: 656
 
Quote:
Originally Posted by flying121 View Post
Do you ride in a lot of mud? Sounds like some serious heat built up in there while the belt was slipping and then it let go. The rollers most likely got so hot the peeled there covers off of the metal inner and burned flat spots into the fixed plate. I had this happen.

Call Adam from Airdam Clutches he is the man when it comes to the CVT clutches and belts. You will be very happy with his work and will not have any future problems once he does his magic.

/// Airdam - Home

Good luck and let us know what you end up with.
I second that!

ROLL TIDE ROLL!!!!


07 Prowler 650 H1 XT
3000lb. Warn winch
2" lift by Highlifter
30" Silverbacks on 14" SS112's
FMF Powercore exhaust
Dynatech CDI box
rejetted with Jets R Us OEM jets
stage 1&2 by ///AIRDAM
clocked secondary to B3
19 gram rollers (red)
2" snorkel by me
chrome skull shifter
LED tail lights in bed by me
fog lights
roof
custom doors by me
custom removable rear cage by me & friends
sandy4bama is offline  
 
post #4 of 5 (permalink) Old 09-06-2010, 07:34 PM Thread Starter
Junior Member
 
billemartin's Avatar
 
Join Date: Jan 2010
Posts: 14
 
I didn't feel the belt slipping. It looks like the rollers and plastic sheets look ok. Maybe just the force slung them out. Took it all apart and looks ok. Won't know till I get the new belt on.

Haven't had good luck...broke axle...and blew whole front diff into two pieces.

I bought it to ride...not to look pretty. So yes it has been through some mud.
billemartin is offline  
post #5 of 5 (permalink) Old 09-06-2010, 11:44 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Quote:
Originally Posted by billemartin View Post
I didn't feel the belt slipping. It looks like the rollers and plastic sheets look ok. Maybe just the force slung them out. Took it all apart and looks ok. Won't know till I get the new belt on.

Haven't had good luck...broke axle...and blew whole front diff into two pieces.

I bought it to ride...not to look pretty. So yes it has been through some mud.
I only asked about the mud because a few guys have had clutch/belt issues during some deep mud crossings. I hear you about buying it to ride but I think it can look good and be ridden hard also. Just a personal preference on how someones ride looks. I have no issues with mud, rocks, sand, water, or any type of riding. I have had to gusset and reinforce just about every part on my XTZ because nearly everything has broke during testing. I hope your clutch and rollers are ok and post up the outcome when you get her fixed.
flying121 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73