ft end knock ??? - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 10-19-2010, 02:54 AM Thread Starter
Jounior Member
 
JPBILLIN's Avatar
 
Join Date: Jul 2010
Location: Phoenix
Posts: 193
 
Question ft end knock ???

when i first start up the prowler and drive it out of my drive way and turn there is a first inital knock in my front end. it seems to do it when the suspension compressed and im turning, but i dont have a problem with it on the trail or high speed could it be my steering or cv shafts i was told to pull them and pack more grease in there. is there any truth to that opinions please... everything is tight up front and 4wd workd great i dont have a locker, 07 650 h1 should i be concerened or just drive the piss out of it haha
JPBILLIN is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 10-19-2010, 10:21 AM
Jounior Member
 
nater's Avatar
 
Join Date: May 2010
Location: utah
Posts: 56
 
I had a similar problem, found the front shock mounts (lower) way too tight. Try loosening the mounts and see if the sound goes away.
nater is offline  
post #3 of 12 (permalink) Old 10-19-2010, 03:05 PM
Rides all the time
 
riddler28's Avatar
 
Join Date: Mar 2010
Location: alaska
Posts: 1,324
 
My noise was tires hiting the bumper when susp. compressed and turning.
I too thought front end but noticed paint rubbed off of bumper and found a clearance issue.
riddler28 is offline  
 
post #4 of 12 (permalink) Old 10-19-2010, 11:19 PM Thread Starter
Jounior Member
 
JPBILLIN's Avatar
 
Join Date: Jul 2010
Location: Phoenix
Posts: 193
 
the only thing rubbing in the ft end is the stupid parking brake cable but its deffinitly a solid noise, ill try the shock mount idea and see what happens
JPBILLIN is offline  
post #5 of 12 (permalink) Old 10-20-2010, 01:47 AM
Founding Member
 
Desertcat's Avatar
 
Join Date: Sep 2008
Location: Arizona
Posts: 3,867
 
It may be a CV knock. If you can determine which one then disassembly, inspect and repack if they look good.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

SETH
TEAM PROWLER NATION
Desertcat is offline  
post #6 of 12 (permalink) Old 10-20-2010, 12:17 PM
Senior Member
 
team arctic's Avatar
 
Join Date: Jun 2010
Location: NORTH POLE ALASKA
Posts: 421
 
My buddy and i have 09-10 xtz`s and they both do it,backing up and turning.usually the first ride of the day,just 1 pop then it doesnt do it any more.havnt located the noise yet!
team arctic is offline  
post #7 of 12 (permalink) Old 03-13-2012, 11:46 PM
Junior Member
 
Join Date: Feb 2011
Posts: 7
 
Hi There ,
I was wondering if you still have the noise ? I have a klink or 2 when I turn . $ wheel drive and suspension still seem fine .???? Any suggestions ??
mantosman is offline  
post #8 of 12 (permalink) Old 03-14-2012, 04:41 AM
Lifetime Member
 
mlh1962's Avatar
 
Join Date: Jul 2011
Location: Lexington, Missouri
Posts: 3,625
 
Garage
Mine is just like the others, I got a used 07 this year and it pops only once in the front end when I first pull it out of the garage. Haven't found the noise yet.

'07 Prowler 650 H1 XT, L.E.D. stop/turn signals, Summit Racing heater, AC winch, AC windshield, soft cab & doors, 6' Eagle Plow, oil gauge, Maxxis MT-762 truck tires, AC Fender Flares, E-Brake alarm, Yutrax UTV Jump Seat, Dynatek CDI
Missouri Mike
mlh1962 is offline  
post #9 of 12 (permalink) Old 03-14-2012, 06:55 AM
Jounior Member
 
arcticcatprowler's Avatar
 
Join Date: Feb 2011
Location: Topeka, Ks.
Posts: 63
 
I had the same issue only the first time when I backed out of garage. Mine hasnt made it sense I put new shocks on and changed mounts. Dont know if that fixed it or what, but it certainly stopped.
arcticcatprowler is offline  
post #10 of 12 (permalink) Old 03-15-2012, 04:45 AM
Senior Member
 
Diesel Racer's Avatar
 
Join Date: Dec 2010
Location: NH
Posts: 799
 
Mine also did it once a day. Been a couple years now and nothing has fallen off or left behind.



Tim

2010 A/C XTZ with some "Stuff" SOLD
But still here everyday to contribute to the cause
Diesel Racer is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73