700 xtx motor cutting off - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-17-2010, 08:56 AM Thread Starter
Jounior Member
 
desh's Avatar
 
Join Date: Nov 2010
Location: Cantley,Quebec Canada
Posts: 222
 
700 xtx motor cutting off

hey guys , my buddy just bought a new 2010 xtx 700 , firs ride last night , as soon he gets in the snow and the wheels start spinning the motor cut's off like if the rev limiter would come on right away. any ideas?, he will bring back to dealer but it is always fun to have a heads up by experinced cat owners so he might have a clue on what is the problem
desh is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-17-2010, 12:03 PM
Senior Member
 
soazcat's Avatar
 
Join Date: Oct 2009
Location: Willcox Az
Posts: 491
 
most likely it is the rev limiter if the wheels are spinning . was it in low ? you can easliler hit the rev limter in low and spinning tires
soazcat is offline  
post #3 of 6 (permalink) Old 12-17-2010, 06:30 PM Thread Starter
Jounior Member
 
desh's Avatar
 
Join Date: Nov 2010
Location: Cantley,Quebec Canada
Posts: 222
 
he was in high and bearly touching the gas
desh is offline  
 
post #4 of 6 (permalink) Old 12-17-2010, 07:20 PM
Loyal Member
 
sandchris's Avatar
 
Join Date: Oct 2008
Location: PEORIA,AZ
Posts: 3,564
 
sandchris is offline  
post #5 of 6 (permalink) Old 12-18-2010, 05:29 AM
Senior Member
 
Triple J's Avatar
 
Join Date: Jan 2010
Location: Minnesota
Posts: 618
 
Not sure if they are the same but on the Yamaha Grizzly 700's when the reverse limit switch goes bad it messed up the forward gears as well.

But then again it should be on dry or in snow unless moisture is shorting it out.

2010 Prowler XTZ 1000-
27" Grim Reaper Tires/Home Made Roof/Arctic Cat Mirror/Quadboss Folding Windshield w/ home made support bar/LED Tail-Brake lights//Venom 4000 lb Winch/Amsteel synthetic line/Home Made Doors/Custom Adjustable Seats/Custom Oh Crap bar for passenger/Tonneau Cover/Fat Max storage Box in bed
Tiger Tail Towing system
Triple J is offline  
post #6 of 6 (permalink) Old 12-18-2010, 06:27 AM
Jounior Member
 
goonski's Avatar
 
Join Date: Jan 2009
Location: Elk Point Alberta
Posts: 90
 
It could be that some snow got into a electrial connector on one of the sensors and is shorting out the sensor. I was running in the snow once and the efi light came on in the dash, so I brought it in the shop overnight to dry it all up, then put dielectic grease in every connector on the machine, never had a problem since.
goonski is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73