clutching problems? - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 04-28-2011, 02:33 PM Thread Starter
Junior Member
 
Catman4u's Avatar
 
Join Date: Mar 2011
Posts: 21
 
clutching problems?

i have a 2011 prowler xtz and I noticed when u take off from a dead stop in high there is some hesitation between 10 and 20 mph for a second. I took it to shop and they put new belt on and said clutch was too tight and the belt was like a banjo string. Got it home today and now it hesitates really bad almost like it cuts out to 20mph. My buddy bought same exact machine and is not having this problem. The hesitation before wasnt bad i only took machine in cuz i could smell belt while riding. now the hesitation is extremely noticeable. Any suggestions. The shop is a very good shop and said everything was good.
Catman4u is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-28-2011, 03:04 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
What do you mean it cuts out or hesitates? Is it a rev limit issue? What rpm are you seeing when you nail the throttle? It may be the spike load damper in the rear end. It may be a roller issue. It might be an ignition issue. It could be a fueling issue. It might be a few other things. Please give details of the cut out or hesitation problem you are having so we can help you.

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
post #3 of 13 (permalink) Old 04-28-2011, 03:05 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Make sure you let the new belt wear in before you get to agressive with the throttle.

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
 
post #4 of 13 (permalink) Old 04-28-2011, 03:07 PM
Senior Member
 
AlmostxProwler's Avatar
 
Join Date: Nov 2010
Location: New Brunswick, Canada
Posts: 733
 
Take it back again if they're good to u and maybe get them to take your clutches off to have a look.. when my xtx was brand new I could smell burning belt and ignored it then I got stranded in the woods alone! lol my belt blew all to pieces... sounds like your secondary is sticking or something... I haven't had any problems since (knock on wood) smell of burning belt = not good!!
AlmostxProwler is offline  
post #5 of 13 (permalink) Old 04-28-2011, 05:08 PM Thread Starter
Junior Member
 
Catman4u's Avatar
 
Join Date: Mar 2011
Posts: 21
 
it is like it is slipping but the belt isnt getting hot. It always had that little second of slip but this is like almost 2 seconds of no acceleration and all of a sudden it takes off like a rocket. It doesnt do it in low only high. I am going to ride all weekend and see if it gets better. I wondered if it was belt needing broke in but I got machine with 0 miles and stock belt didnt do it at all like this. The dealer said if it dont quit they will tear it apart. They had clutch all apart and everything looked good.
Catman4u is offline  
post #6 of 13 (permalink) Old 04-28-2011, 05:11 PM Thread Starter
Junior Member
 
Catman4u's Avatar
 
Join Date: Mar 2011
Posts: 21
 
I forgot to say when I am at dead stop and punch it from 0 to 10 it throws you back in seat and then the lag for couple seconds then rockets again. It is very weird feeling. I have had arctic cat quads and now prowler and never felt this and my quad had 4000 miles on it.
Catman4u is offline  
post #7 of 13 (permalink) Old 04-28-2011, 05:15 PM
Loyal Member
 
sandchris's Avatar
 
Join Date: Oct 2008
Location: PEORIA,AZ
Posts: 3,564
 
Sounds to me like you have a secondary clutch that is sticking. The secondary is where i would look first. Then possibly a bad roller or two in the primary



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
sandchris is offline  
post #8 of 13 (permalink) Old 04-28-2011, 07:52 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Are you in Arizona?

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
post #9 of 13 (permalink) Old 04-28-2011, 07:54 PM
Loyal Member
 
sandchris's Avatar
 
Join Date: Oct 2008
Location: PEORIA,AZ
Posts: 3,564
 
Yea I am in Az.
Quote:
Originally Posted by flying121 View Post
Are you in Arizona?


Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
sandchris is offline  
post #10 of 13 (permalink) Old 04-28-2011, 07:55 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Quote:
Originally Posted by Catman4u View Post
I forgot to say when I am at dead stop and punch it from 0 to 10 it throws you back in seat and then the lag for couple seconds then rockets again. It is very weird feeling. I have had arctic cat quads and now prowler and never felt this and my quad had 4000 miles on it.
Sounds like you are releasing the Nitrous button so just keep it longer!

I had the same problem in a 1990 Mustang that had a built motor and a 150 shot of nitrous. It pulled hard then it would stop and then pull hard again. And that was just chasing down the guys i wanted to race.

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73