Four Wheel drive works but not Diff Lock?? - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-09-2011, 12:46 PM Thread Starter
Senior Member
 
AlmostxProwler's Avatar
 
Join Date: Nov 2010
Location: New Brunswick, Canada
Posts: 733
 
Question Four Wheel drive works but not Diff Lock??

Hey guys.. I have a 2010 xtx... my four wheel drive works just fine but my diff lock only works every once and a while.. anybody know what might be causing this?? I thought maybe its a weak battery? if not maybe the actuator? any ideas or anybody that has encountered this any help would be appreciated..
AlmostxProwler is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-09-2011, 04:45 PM
Loyal Member
 
sandchris's Avatar
 
Join Date: Oct 2008
Location: PEORIA,AZ
Posts: 3,564
 
If it is intermitten it has to be the actuator or the switch. it is either gonna work or not on the mechanical end of things. So either engaged or not. If it works sometimes leads me to believe it is ok on the hard parts.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
sandchris is offline  
post #3 of 3 (permalink) Old 08-12-2011, 05:53 AM Thread Starter
Senior Member
 
AlmostxProwler's Avatar
 
Join Date: Nov 2010
Location: New Brunswick, Canada
Posts: 733
 
Quote:
Originally Posted by sandchris View Post
If it is intermitten it has to be the actuator or the switch. it is either gonna work or not on the mechanical end of things. So either engaged or not. If it works sometimes leads me to believe it is ok on the hard parts.
well thats good i guess cuz that means I can at least fix whats wrong with it... its started acting up after a really wet ride so I was wondering if maybe water got in the actuator? can it be taken apart for servicing? would a weak battery cause this too? Maybe I'll start with the connection to the actuator.. It might be the only part that I missed with the di electric grease and wire dry treatment..
Thanks Chris
AlmostxProwler is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73