Diff lock not working - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-14-2011, 02:13 PM Thread Starter
Senior Member
 
AlmostxProwler's Avatar
 
Join Date: Nov 2010
Location: New Brunswick, Canada
Posts: 733
 
Unhappy Diff lock not working

Hey all! good to finally be back.. and now I have a question.. My four wheel drive works (most of the time). sometimes it wont engage right away and it seem that my diff lock isn't working at all now.. I checked the switch and its fine just wondering if anybody has run in to this problem and/or if the actuator unit can be taken apart.. Thanks guys
AlmostxProwler is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-15-2011, 09:18 AM Thread Starter
Senior Member
 
AlmostxProwler's Avatar
 
Join Date: Nov 2010
Location: New Brunswick, Canada
Posts: 733
 
Nobody has had actuator problems?
AlmostxProwler is offline  
post #3 of 5 (permalink) Old 09-15-2011, 10:21 AM
Jounior Member
 
gone2thehills's Avatar
 
Join Date: Dec 2009
Location: Los Anchorage, AK
Posts: 282
 
should be able to pull the actuator out and test it to make sure its operating properly, you can also hear it pretty good if you get down there and listen. I have the cable actuated diff so Im not sure the difference between the actuator with diff lock and without. My actuator only controls the 4x4

You could pull out your front axel, passenger side, and look in there and make sure the collar is moving when you throw the actuator. In my case everything checked out, I pulled my axel, inspected, and put it back in and everything works, I suggest you do the same. I would say your axel may have popped out and is not engaging the collar inside the diff.
gone2thehills is offline  
 
post #4 of 5 (permalink) Old 09-15-2011, 01:03 PM
Rides all the time
 
riddler28's Avatar
 
Join Date: Mar 2010
Location: alaska
Posts: 1,324
 
My inlaws 2010hdx had a actuator failure.
Warrenty covered it and I don't know what the issue was sorry.
riddler28 is offline  
post #5 of 5 (permalink) Old 09-15-2011, 01:13 PM Thread Starter
Senior Member
 
AlmostxProwler's Avatar
 
Join Date: Nov 2010
Location: New Brunswick, Canada
Posts: 733
 
Thanks guys.. Yeah, i think its my actuator mine's a 2010 as well but no warrenty oh well.. guess I'll have to order one if I can't get it apart..
AlmostxProwler is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73