Need help! - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-09-2012, 10:25 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 4
 
Need help!

So I got my prowler home and decided to give er a once over. Changed the oil, gapped a new plug and put it in. Got some intake cleaner and sprayed it into the intake to clean er out. Bought a new UNI air filter, oiled and installed it. Started it up, runs awesome but give er some gas and it started to burn oil?? I know it didn't do this when I was test driving it before I bought it. Do I need to do a top end?? Engine only has 560 kms on it. Any help would be appreciated.

2009 Prowler 700 XTX
UNI Air filter
Maxxis Zilla's 28's
Chevaholic is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-10-2012, 06:13 AM
Senior Member
 
Triple J's Avatar
 
Join Date: Jan 2010
Location: Minnesota
Posts: 618
 
Are you sure the air filter isn't over-oiled?

2010 Prowler XTZ 1000-
27" Grim Reaper Tires/Home Made Roof/Arctic Cat Mirror/Quadboss Folding Windshield w/ home made support bar/LED Tail-Brake lights//Venom 4000 lb Winch/Amsteel synthetic line/Home Made Doors/Custom Adjustable Seats/Custom Oh Crap bar for passenger/Tonneau Cover/Fat Max storage Box in bed
Tiger Tail Towing system
Triple J is offline  
post #3 of 4 (permalink) Old 03-10-2012, 10:34 PM Thread Starter
Junior Member
 
Join Date: Mar 2012
Posts: 4
 
Quote:
Originally Posted by Triple J View Post
Are you sure the air filter isn't over-oiled?
I don't think so, I used bel-ray foam filter oil, the same stuff I used on my Grizzly and on my YZ 250.

2009 Prowler 700 XTX
UNI Air filter
Maxxis Zilla's 28's
Chevaholic is offline  
 
post #4 of 4 (permalink) Old 03-11-2012, 07:11 AM
Senior Member
 
Diesel Racer's Avatar
 
Join Date: Dec 2010
Location: NH
Posts: 799
 
Quote:
Originally Posted by Chevaholic View Post
So I got my prowler home and decided to give er a once over. Changed the oil, gapped a new plug and put it in. Got some intake cleaner and sprayed it into the intake to clean er out. Bought a new UNI air filter, oiled and installed it. Started it up, runs awesome but give er some gas and it started to burn oil?? I know it didn't do this when I was test driving it before I bought it. Do I need to do a top end?? Engine only has 560 kms on it. Any help would be appreciated.
Betting it is burning this off and you are seeing the result.



Tim

2010 A/C XTZ with some "Stuff" SOLD
But still here everyday to contribute to the cause
Diesel Racer is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73