XTZ has EFI code flashing - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools
Old 05-07-2012, 09:06 PM Thread Starter
Junior Member
 
Join Date: Apr 2012
Posts: 35
 
XTZ has EFI code flashing

cranked up the XTZ to clean it up today and it started flashing EFI everytime I cranked it up. It seemed to still run ok, but it did die once while idling. Anybody know whats going on?
rayford118 is offline  
Sponsored Links
Advertisement
 
Old 05-07-2012, 09:09 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Check the connection that goes into your fuel tank. It is a four wire harness with a connector that comes off of the top of your fuel tank. This goes to your sending unit, and fuel pump. Check all connectors around the throttle body. TPS, MAP, ICU etc....

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
Old 05-08-2012, 09:59 AM Thread Starter
Junior Member
 
Join Date: Apr 2012
Posts: 35
 
Ok will check the fuel tank when i get home tonight. sorry but you will have to help me on where the other connectors are (throttle body, tps, map, icu, etc). I know a polaris machine really well but this is my first cat so real green when it comes to fixing these minor issues. I read the post on Accessing Codes and on step #3 (3. Connect the Test Plug from Test Plug/Error Code List to the diagnostic plug.), what is this? is it something i have to purchase to check the codes or did it come with prowler. thanks for the help
rayford118 is offline  
 
Old 05-08-2012, 12:16 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Number 3, 6 , and 10. The plug you are talking about is part number 0486-219 from Arctic Cat.
Attached Thumbnails
Click image for larger version

Name:	XTZ TB.jpg
Views:	656
Size:	15.5 KB
ID:	2884   Click image for larger version

Name:	IMG_1413.jpg
Views:	889
Size:	97.6 KB
ID:	2885  

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
Old 05-08-2012, 05:05 PM
Jounior Member
 
Join Date: Dec 2010
Posts: 97
 
you can use a jumper wire, just put it on the right pins. also, his is a 2011, thought they displayed the code for you?
mr. potato head is offline  
Old 05-08-2012, 07:33 PM Thread Starter
Junior Member
 
Join Date: Apr 2012
Posts: 35
 
checked the plugs under the seat and made sure they were still plugged in all the way. Potato head, explain the jumper wire and which pins to put them in. will this allow me to check the codes? trying to avoid having to bring the bike in to dealer
rayford118 is offline  
Old 05-08-2012, 09:13 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Yes but you need to know what the numbers are. Post them up and someone here can tell you.

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
Old 05-08-2012, 09:14 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Quote:
Originally Posted by rayford118 View Post
checked the plugs under the seat and made sure they were still plugged in all the way. Potato head, explain the jumper wire and which pins to put them in. will this allow me to check the codes? trying to avoid having to bring the bike in to dealer
Unplug and replug just to be sure.

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
Old 05-08-2012, 09:14 PM
Loyal Member
 
flying121's Avatar
 
Join Date: Mar 2009
Posts: 2,390
 
Quote:
Originally Posted by rayford118 View Post
checked the plugs under the seat and made sure they were still plugged in all the way. Potato head, explain the jumper wire and which pins to put them in. will this allow me to check the codes? trying to avoid having to bring the bike in to dealer
Unplug and replug just to be sure.

2009 Prowler XTZ 1000 with a few modifications. Needs paint & powder coating.
flying121 is offline  
Old 05-09-2012, 01:20 PM
Jounior Member
 
Join Date: Dec 2010
Posts: 97
 
I'd have to look but it seems the plug only has 2 pins in it. I'm probably wrong maybe someone will know. But I thought the 2011 xtz gave you the code on the display. Only thing mine has done was P0625 don't know about anything else. On vince's we did the jumper wire and it worked but his is a 10
mr. potato head is offline  
Sponsored Links
Advertisement
 
 

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73