help needed - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 08-06-2013, 07:52 AM Thread Starter
Senior Member
 
Fat Cat's Avatar
 
Join Date: Oct 2011
Location: manitoba,canada
Posts: 561
 
help needed

okay a friend of mine has a 2009 prowler 1000. Here is what it did to him on the weekend. He was driving a long and then it just died. It turns over there is lots of spark. If you let it sit for about an hour it will try to start run for a few seconds and then die.
I have no experience with this so your input would be most helpful. I'm thinking maybe stator, fuel pump, or ecu. I got the service manual for it. I'm going to check fuel pressure and the stator on the weekend.

Ant thought would be appreciated.

Rob
Fat Cat is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 08-06-2013, 08:01 AM
Lifetime Member
 
mlh1962's Avatar
 
Join Date: Jul 2011
Location: Lexington, Missouri
Posts: 3,621
 
Garage
Seems like somebody else just had the same problem and it turned out to be the plug even though they had spark when they checked it.

'07 Prowler 650 H1 XT, L.E.D. stop/turn signals, Summit Racing heater, AC winch, AC windshield, soft cab & doors, 6' Eagle Plow, oil gauge, Maxxis MT-762 truck tires, AC Fender Flares, E-Brake alarm, Yutrax UTV Jump Seat, Dynatek CDI
Missouri Mike
mlh1962 is offline  
post #3 of 12 (permalink) Old 08-06-2013, 08:09 AM
Lifetime Member
 
mlh1962's Avatar
 
Join Date: Jul 2011
Location: Lexington, Missouri
Posts: 3,621
 
Garage
www.prowlertalk.net/forums/arctic-cat-prowler-general-discussions/7250-09-550-wont-fire.html

Here's the thread

'07 Prowler 650 H1 XT, L.E.D. stop/turn signals, Summit Racing heater, AC winch, AC windshield, soft cab & doors, 6' Eagle Plow, oil gauge, Maxxis MT-762 truck tires, AC Fender Flares, E-Brake alarm, Yutrax UTV Jump Seat, Dynatek CDI
Missouri Mike
mlh1962 is offline  
 
post #4 of 12 (permalink) Old 08-06-2013, 09:04 AM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Rob X2 on the plug Rob like mlh1962 said just had the same problem a week or so ago,the member had spark,and he could go about 1/4 mile then it would shut down.It's a cheap try,or like you said ECU breaking down,But I would check battery voltage,before you start it and after its running.with the prowler running it should be around 14.0 to 15.3.

2015 A/C Sport,With a few add ons..........
de3 is offline  
post #5 of 12 (permalink) Old 08-06-2013, 02:39 PM
Loyal Member
 
GTroyer's Avatar
 
Join Date: Nov 2009
Location: Reno/Sparks ,Nv.
Posts: 3,289
 
other than plug as stated , is the existing plug wet with fuel [about the only way to check if he's getting fuel with injection without pulling injector and testing it] ... is spark he is getting strong ?

name is Gary or hey you if ya forget

2009 Prowler XTZ , couple things added here and there
'83 CJ7 / SBC + whole lot added here and there
'01 Dodge / Cummins / Dually, a ton of stuff added here and there

INSTRUCTIONS FOR THE NEWBIES ...
1. Bring in a good load of firewood for the pit
2. start the morning coffee , strong but not burnt / boiled down , IMPORTANT start it early as many of us old farts get up early !!
3. sit a spell and swap some lies with the best of us
GTroyer is offline  
post #6 of 12 (permalink) Old 08-06-2013, 03:22 PM
Jounior Member
 
blowinsoot00's Avatar
 
Join Date: Jul 2012
Location: Goodyear Az
Posts: 250
 
being a 1000 twin, what are the chances of both plugs going bad at the same time? that motor should run like pure sh$t on 1 cylinder but you should still be able to keep it running. i would lean towards fuel supply or cdi. isnt there a schrader valve on the fuel rail to check pressure?

09 xtx- custom fox 2.0 air shocks- bighorn tires- custom paint- 4 seat cage built by me- soft top- twisted stitch seats- half doors- intake built by me- magnaflow exhaust built by me- carillo 4 point harnesses all around- 5 h.i.d.'s- clutch kit- dynatek- no more turf saver...tig welded now- 2" wheel spacers- ss-212 rims in black-
blowinsoot00 is offline  
post #7 of 12 (permalink) Old 08-06-2013, 03:27 PM
Jounior Member
 
notapoofan's Avatar
 
Join Date: Mar 2010
Location: Northern Mn
Posts: 109
 
Do the simple cheap obvious first. Put new plugs in it. Then go from there.
notapoofan is offline  
post #8 of 12 (permalink) Old 08-06-2013, 03:29 PM
Jounior Member
 
notapoofan's Avatar
 
Join Date: Mar 2010
Location: Northern Mn
Posts: 109
 
I had good spark on mine also. But under compression it would lose spark. Replaced the plug and she runs like a champ!!!
notapoofan is offline  
post #9 of 12 (permalink) Old 08-06-2013, 03:52 PM
Lifetime Member
 
mlh1962's Avatar
 
Join Date: Jul 2011
Location: Lexington, Missouri
Posts: 3,621
 
Garage
Quote:
Originally Posted by blowinsoot00 View Post
being a 1000 twin, what are the chances of both plugs going bad at the same time? that motor should run like pure sh$t on 1 cylinder but you should still be able to keep it running. i would lean towards fuel supply or cdi. isnt there a schrader valve on the fuel rail to check pressure?
I didn't even think about it being a twin I'm use to dealing with the one lung.

'07 Prowler 650 H1 XT, L.E.D. stop/turn signals, Summit Racing heater, AC winch, AC windshield, soft cab & doors, 6' Eagle Plow, oil gauge, Maxxis MT-762 truck tires, AC Fender Flares, E-Brake alarm, Yutrax UTV Jump Seat, Dynatek CDI
Missouri Mike
mlh1962 is offline  
post #10 of 12 (permalink) Old 08-06-2013, 08:11 PM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Quote:
Originally Posted by blowinsoot00 View Post
being a 1000 twin, what are the chances of both plugs going bad at the same time? that motor should run like pure sh$t on 1 cylinder but you should still be able to keep it running. i would lean towards fuel supply or cdi. isnt there a schrader valve on the fuel rail to check pressure?
DJ,He really didn't tell us if it was running rough or not.????????? he will chime in after bit.

2015 A/C Sport,With a few add ons..........
de3 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73