Gauge Help - Arctic Cat Prowler Forums: Prowler UTV Forum
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-07-2013, 06:59 PM Thread Starter
Jounior Member
 
Join Date: Apr 2013
Location: Garrison ND
Posts: 57
 
Gauge Help

Hey All, im diving into my last project so I can hopefully get the beast back up and running by weeks end. I have the gauges all mounted, power to the lights and the gauges, all I have left to complete is install the sending units and wire em up. Ive been digging through the many threads on the oil press/coolant temp gauge installs, yet dont seem to have the 1 question I have answered.

Where do I put the sending units?

I have a 2010 xtz

I assume the coolant temp sending unit goes on the big hose that comes off the water pump, my only question to this is that appears to be the input to the water pump, so the water temp will be read after it has gone through the radiator. This is the line that comes off the bottom of the radiator. Is this correct?

I also assume that the oil press. sending unit will tie into the line that runs along the drivers side frame rail and ties into the port next to the oil filter? I do have a oil cooler.

Are these assumptions correct, and would anybody happen to have pictures to guide me along my path.

Thanks!!!
Bauer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-08-2013, 03:12 AM
Senior Member
 
Diesel Racer's Avatar
 
Join Date: Dec 2010
Location: NH
Posts: 799
 
I thought about going into the thermostat housing myself but I think there is a member here who took his apart and actually got it to fit there, oil pressure I do not know.



Tim

2010 A/C XTZ with some "Stuff" SOLD
But still here everyday to contribute to the cause
Diesel Racer is offline  
post #3 of 5 (permalink) Old 08-08-2013, 05:30 AM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Quote:
Originally Posted by Bauer View Post
Hey All, im diving into my last project so I can hopefully get the beast back up and running by weeks end. I have the gauges all mounted, power to the lights and the gauges, all I have left to complete is install the sending units and wire em up. Ive been digging through the many threads on the oil press/coolant temp gauge installs, yet dont seem to have the 1 question I have answered.

Where do I put the sending units?

I have a 2010 xtz

I assume the coolant temp sending unit goes on the big hose that comes off the water pump, my only question to this is that appears to be the input to the water pump, so the water temp will be read after it has gone through the radiator. This is the line that comes off the bottom of the radiator. Is this correct?

I also assume that the oil press. sending unit will tie into the line that runs along the drivers side frame rail and ties into the port next to the oil filter? I do have a oil cooler.

Are these assumptions correct, and would anybody happen to have pictures to guide me along my path.

Thanks!!!
I am not sure how your 1000 is set up,but on my 650 I have my temp sending unit coming off my thermostat which is the top hose on the motor,and on the oil pressure I used the bottom port under the oil filter.

2015 A/C Sport,With a few add ons..........
de3 is offline  
 
post #4 of 5 (permalink) Old 08-08-2013, 03:47 PM Thread Starter
Jounior Member
 
Join Date: Apr 2013
Location: Garrison ND
Posts: 57
 
What do you mean by bottom port, it looks to me like I have only 1 port where if you were standing in front of the prowler looking at the front of the engine, the oil filter is bottom right and then the cooler line comes in to the right of the filter. Ideas?? Photos???

Thanks
Bauer is offline  
post #5 of 5 (permalink) Old 08-08-2013, 08:25 PM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Quote:
Originally Posted by Bauer View Post
What do you mean by bottom port, it looks to me like I have only 1 port where if you were standing in front of the prowler looking at the front of the engine, the oil filter is bottom right and then the cooler line comes in to the right of the filter. Ideas?? Photos???

Thanks
The 1000 motor sits in there different than the 650 or 700,The easiest way to tell is just take your lines off and just crank the motor,you will see real quick which one the oil comes out first,and hook your sending into that line.

2015 A/C Sport,With a few add ons..........
de3 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73