fuel pump - Arctic Cat Prowler Forums: Prowler UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-06-2013, 10:15 PM Thread Starter
Junior Member
 
Join Date: Nov 2013
Location: Elko Nevada
Posts: 2
 
fuel pump

Hi! This is Kelley and I'm looking for anybody that can help me with fuel pump problems on 2010 prowler side by side
kelleyreynolds is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-06-2013, 10:26 PM
Senior Member
 
cClark06's Avatar
 
Join Date: Jun 2013
Location: St. Clairsville, Ohio
Posts: 404
 
Can you give us more information on the problem?

2013 Arctic Cat Xtz 1000 - Glass Windshield, Wiper Kit, Roof, Radio, Winch, V Bag, And Yutrax No Drill Rumble Seat
2007 Suzuki Sv1000s - Stock Vigor Blue Metallic
1999 Honda 300 4x4 - Wiseco Bbk, H/L Clutch Kit, Gearless Locker, Disc Brake Conversion, Lift Kit, and 18" Snorkel, Sitting on 28" Itp 589s With C Series Wheels

Name - Chaz
cClark06 is offline  
post #3 of 7 (permalink) Old 11-06-2013, 11:59 PM Thread Starter
Junior Member
 
Join Date: Nov 2013
Location: Elko Nevada
Posts: 2
 
fuel pump

on my 2010 arctic cat 1000 prowler I picked up a high pitch whistle in the fuel pump on the hunts this year we were putting 100 miles a day on it. I got a code that read EFI we reset it and it has not returned but I still got the high pitch noise I was told it could be the fuel pump only got 1400 miles on the machine[]
kelleyreynolds is offline  
 
post #4 of 7 (permalink) Old 11-07-2013, 07:59 AM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Quote:
Originally Posted by kelleyreynolds View Post
on my 2010 arctic cat 1000 prowler I picked up a high pitch whistle in the fuel pump on the hunts this year we were putting 100 miles a day on it. I got a code that read EFI we reset it and it has not returned but I still got the high pitch noise I was told it could be the fuel pump only got 1400 miles on the machine[]
You might want to pick up a spare,but I would run it till it quit's .............my opinion. let us know what you find out.

2015 A/C Sport,With a few add ons..........
de3 is offline  
post #5 of 7 (permalink) Old 11-07-2013, 08:17 AM
Loyal Member
 
GTroyer's Avatar
 
Join Date: Nov 2009
Location: Reno/Sparks ,Nv.
Posts: 3,291
 
also welcome to the house from another XTZ owner

fill in your signature line so we don't half to ask a question before we reply .... also area/town helps so we have a clue as to ride area/type of riding .. again help us answer better sometimes.

name is Gary or hey you if ya forget

2009 Prowler XTZ , couple things added here and there
'83 CJ7 / SBC + whole lot added here and there
'01 Dodge / Cummins / Dually, a ton of stuff added here and there

INSTRUCTIONS FOR THE NEWBIES ...
1. Bring in a good load of firewood for the pit
2. start the morning coffee , strong but not burnt / boiled down , IMPORTANT start it early as many of us old farts get up early !!
3. sit a spell and swap some lies with the best of us
GTroyer is offline  
post #6 of 7 (permalink) Old 11-07-2013, 02:49 PM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,125
 
Any other issues, or just the EFI code, and high pitched noise? I have an 09 EFI Prowler and have not had any EFI, or fuel pump related problems.

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #7 of 7 (permalink) Old 11-07-2013, 04:26 PM
Lifetime Member
 
muddogefi's Avatar
 
Join Date: Jan 2011
Location: r.i.
Posts: 1,083
 
a week pump will cause it to sputter when you take off....lack of pressure a loud pump is usualy a sighn of a bad pump or its struggling to pump fuel

2012 prowler xtx custom doors ,bumpers ,lightbar,windshield.rollcage ,stereo,5000lb winch,28"wsamp lites ,1 1/2"wheel spacers.custom graphics,custom rear roll bar,factory fender flares cb radio ltz hoodscoop ac soft top and rear window,ac aluminium skidplates,temp and volt guage ,2"lift kit and sti beadlock wheels
muddogefi is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58