XTZ Efi light - Arctic Cat Prowler Forums: Prowler UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-02-2009, 09:56 AM Thread Starter
Junior Member
 
Join Date: Dec 2009
Posts: 4
 
XTZ Efi light

I just got a new xtz, and i've had the efi light come on twice now. Different things i've read says to make sure the battery is fully charged and it is. The closet dealer is a couple hours, so I was wondering if anyone had any ideas first!
jeremy0204 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-02-2009, 10:22 AM
Senior Member
 
Join Date: Jun 2009
Location: N.E. Ohio
Posts: 463
 
Nope never heard of that problem. Give it time on here and someone will give you some info. Congrats on your new machine though.
cat n hat is offline  
post #3 of 6 (permalink) Old 12-02-2009, 10:54 AM
Founding Member
 
Darryl89's Avatar
 
Join Date: Oct 2008
Location: Farmington, NM
Posts: 1,048
 
Had my EFI light come on once a few weeks ago while I was running hard in a sandwash. It went off within a minute and never has come back on. I checked all my wiring, the filter and nothing looked wrong. Stymied...I may have found some way to starve it for fuel running in the washes with repeated jumps and corners.

Arctic Cat Prowler Desert Race XTZ: ITP BajaCross tires on ITP Beadlocks, Beard Super TZ Seats, Crowe 5pt harnesses, King Off-Road Racing Shocks, Custom Racing Chassis with 7 inch longer wheelbase, +5 Suspension set at 16 Front and 17 inches Rear inches travel, UTVINC did the tube bending
TEAM PROWLER NATION...
Darryl89 is offline  
 
post #4 of 6 (permalink) Old 12-02-2009, 11:41 AM
Jounior Member
 
brandon_xtz's Avatar
 
Join Date: Apr 2009
Location: Temecula, Ca
Posts: 142
 
When I rebuilt my motor I forgot to plug in the map sensor I think or one of those sensors and got the EFI light.. Check all the plugs on the motor and make sure they are all clipped in..
brandon_xtz is offline  
post #5 of 6 (permalink) Old 12-02-2009, 09:57 PM
Jounior Member
 
goonski's Avatar
 
Join Date: Jan 2009
Location: Elk Point Alberta
Posts: 90
 
I got an xtx 700 and my efi light came on last winter after charging through deep snow, I think some snow melted in one of the connections for one of the sensors, so I put dielectric grease in every electrical connector on that machine and never had a problem since!

Goon
goonski is offline  
post #6 of 6 (permalink) Old 12-02-2009, 10:54 PM Thread Starter
Junior Member
 
Join Date: Dec 2009
Posts: 4
 
Quote:
Originally Posted by goonski View Post
I got an xtx 700 and my efi light came on last winter after charging through deep snow, I think some snow melted in one of the connections for one of the sensors, so I put dielectric grease in every electrical connector on that machine and never had a problem since!

Goon

The thing of it is, is I hadn't even drove it yet. The light was on, then off, but now came back on again tonight when I cleared my driveway.. Just wondering if it could be a bad injector?
jeremy0204 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72