Prowler 700 hdx fuel pump? - Arctic Cat Prowler Forums: Prowler UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-25-2015, 03:45 PM Thread Starter
Junior Member
 
Join Date: Jun 2015
Posts: 4
 
Prowler 700 hdx fuel pump?

Need a new fuel pump on the prowler and was wondering if any one know of a after market pump that I can use on it that no 400$?
RaymondT is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-25-2015, 04:57 PM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,081
 
Not that I'm aware of, you could find a used one, but then you are taking a risk.

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #3 of 7 (permalink) Old 07-02-2015, 06:36 PM Thread Starter
Junior Member
 
Join Date: Jun 2015
Posts: 4
 
I still can't get it started can some one help plz new fuel pump has spark has fuel all conecters are good turns over fine just won't start!
RaymondT is offline  
 
post #4 of 7 (permalink) Old 07-03-2015, 03:15 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,081
 
Is it firing at all? Any codes on the gage cluster? Did it overheat?

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #5 of 7 (permalink) Old 07-04-2015, 01:25 AM Thread Starter
Junior Member
 
Join Date: Jun 2015
Posts: 4
 
No over heat no codes the pump is at around 43 psi its getting spark cranking over good just won't fire the spark plunk is getting wet and it a brand to plug
RaymondT is offline  
post #6 of 7 (permalink) Old 07-04-2015, 04:45 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,081
 
You said the plug is firing when you ground the plug out? How is your timing? These things are pretty basic, timing, or lack of compression would keep it from running. How is your spark arrestor in the muffler? I'm reaching on this but could create a problem. You have spark, and fuel so the basics are covered, it should run!

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #7 of 7 (permalink) Old 07-04-2015, 07:49 AM
de3
Loyal Member
 
de3's Avatar
 
Join Date: Mar 2012
Location: parkersburg wva
Posts: 8,040
 
Quote:
Originally Posted by RaymondT View Post
No over heat no codes the pump is at around 43 psi its getting spark cranking over good just won't fire the spark plunk is getting wet and it a brand to plug
RaymondT....try doing a compression check .......

2015 A/C Sport,With a few add ons..........
de3 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72