Speedo not working - Arctic Cat Prowler Forums: Prowler UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-25-2010, 08:36 AM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 3
 
Speedo not working

Anyone have the same problem? I have a 650 Prowler,everthing else works.Time,R.P.M.,Lighted Bezel,Clock,any suggestions?
clutch is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-25-2010, 11:23 AM
Founding Member
 
Desertcat's Avatar
 
Join Date: Sep 2008
Location: Arizona
Posts: 3,867
 
No problems here. Have you looked at a wiring schematic? I wonder where the speedo sensor is?



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

SETH
TEAM PROWLER NATION
Desertcat is offline  
post #3 of 10 (permalink) Old 04-25-2010, 11:52 AM
Rides all the time
 
Mustanggeek's Avatar
 
Join Date: Nov 2008
Location: Phoenix, AZ
Posts: 1,510
 
Will it not switch over from RPM to Speedo or it switches, but MPH says zero?
Mustanggeek is offline  
 
post #4 of 10 (permalink) Old 04-25-2010, 06:31 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 3
 
It switches over from r.p.m. to speedo ,but speedo always shows o
clutch is offline  
post #5 of 10 (permalink) Old 04-25-2010, 06:45 PM
Founding Member
 
Desertcat's Avatar
 
Join Date: Sep 2008
Location: Arizona
Posts: 3,867
 
Desertcat is offline  
post #6 of 10 (permalink) Old 05-05-2010, 08:23 PM
Junior Member
 
camperman's Avatar
 
Join Date: May 2010
Posts: 4
 
Mine works sometimes and sometimes not. Also I have no emergency brake. Very frustrated!
camperman is offline  
post #7 of 10 (permalink) Old 05-06-2010, 08:28 AM
Jounior Member
 
Bipolar Jim's Avatar
 
Join Date: Nov 2008
Location: Yacolt, Washington
Posts: 105
 
On the 650 and some 700's there is a small gear that runs the speedo its on the side of the block behind a plug around the shift leaver. this gear has had lots of problems (it comes apart). Three torque bolts to expose it and whats left of it pulls out the replacement gear is made of better material.

Jim
Bipolar Jim is offline  
post #8 of 10 (permalink) Old 05-10-2010, 12:51 AM
Founding Member
 
Desertcat's Avatar
 
Join Date: Sep 2008
Location: Arizona
Posts: 3,867
 
Quote:
Originally Posted by Bipolar Jim View Post
On the 650 and some 700's there is a small gear that runs the speedo its on the side of the block behind a plug around the shift leaver. this gear has had lots of problems (it comes apart). Three torque bolts to expose it and whats left of it pulls out the replacement gear is made of better material.

Jim


Thanks for the info Jim



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

SETH
TEAM PROWLER NATION
Desertcat is offline  
post #9 of 10 (permalink) Old 05-10-2010, 10:01 AM
Rides all the time
 
Mustanggeek's Avatar
 
Join Date: Nov 2008
Location: Phoenix, AZ
Posts: 1,510
 
Clutch, did you figure out why the speedo isn't working?
Mustanggeek is offline  
post #10 of 10 (permalink) Old 05-31-2010, 07:49 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 3
 
Just started working today,I checked out what Bipolar Jim had sent Me and I only see 2 bolts with a wire attached.Wondered if this was it?Wont worry about it to it happens again,maybe I"ll get luckyl
clutch is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72