Hi everybody - Arctic Cat Prowler Forums: Prowler UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 02-14-2018, 04:30 PM Thread Starter
New Member
 
Join Date: Feb 2018
Location: Rushford, MN
Posts: 4
 
Hi everybody

Hi guys,
not sure why i haven't joined until now, but anyway here I go. I have a 2007 650 prowler, i should say it was a 650. The motor died in it and instead of rebuilding, my dad bought a kawi mule pro-fx. I "inherited" his prowler and dragged it to my house in order to resurrect it. Bought a lot of parts from speedwerx, including the 700 BB kit, new cam, and titanium valve springs. Also got new timing chain guides, timing chain, and tensioner, and speedwerx recommended jetting. Put put back together, and man does it rip, when it wants to start. Very hard starting when it has been sitting. checked, and rechecked valve clearances, replaced the electric choke, and still found that usually i could only get it to start when cold by using my hand to cover the intake. I also found that a rear halfshaft and wheel hub decided they should be smooth, and thusly flattened out the splines. Oh well, winter was fast approaching and i needed to get my sled ready. Parked it for the winter. After this craptastic winter, i am already itching to finish off the prowler, so I will be ordering a manual choke kit i found on ebay, and getting a new halfshaft and wheel hub coming my way.

Sorry for the long winded opener, but Hi and great site!

fathead.
fathead is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 02-14-2018, 08:01 PM
Loyal Member
 
GTroyer's Avatar
 
Join Date: Nov 2009
Location: Reno/Sparks ,Nv.
Posts: 3,291
 
howdy back at ya ... fill in your signature lines and also location , helps us answer questions without additional questions

also read my signature for further newby instruction

bunch of good wrenches on here and will pitch in and help usually in one day , and a big plus is we're all full of BS so join in and have some fun

name is Gary or hey you if ya forget

2009 Prowler XTZ , couple things added here and there
'83 CJ7 / SBC + whole lot added here and there
'01 Dodge / Cummins / Dually, a ton of stuff added here and there

INSTRUCTIONS FOR THE NEWBIES ...
1. Bring in a good load of firewood for the pit
2. start the morning coffee , strong but not burnt / boiled down , IMPORTANT start it early as many of us old farts get up early !!
3. sit a spell and swap some lies with the best of us
GTroyer is offline  
post #3 of 16 (permalink) Old 02-14-2018, 08:17 PM
Moderator
 
Bryan's Avatar
 
Join Date: Dec 2014
Location: Eastern most Iowa
Posts: 1,025
 
Welcome to the forum! Here is a quick fix that worked for me, same condition you have. There is a hose coming off the carb bowl, that runs back, between the seats and hangs down around the snorkels. Plug that hose. It lets fuel evaporate from the carb bowl. Might not fix yours, but has fixed several other 650 owners hard start problem. Interested in your motor mods, keep us up to date on how she runs!

'09 650XT H1, 72" Eagle Plow, Warn 3500 Winch. Dyna CDI box, UNI filters, A/C V-bag and console, EPI lift kit, Highlifter springs, Scat ProCar suspension seats. Rick the Rockets A frame and shock bushings. 28x12X14 Raceline Bruisers on Vision rims, on all corners. Cowling heat vents. Factory heat and defrost. RD's custom alternator kit. XTZ hood scoop and front shocks. Monster shock covers, turn signals. OEM glass sport windshield, sliding rear window, and lights, lights and more lights!
Bryan is offline  
 
post #4 of 16 (permalink) Old 02-15-2018, 04:35 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,123
 
Always great to add new member! Best site/Best People/Most fun! Sounds like an interesting project!

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #5 of 16 (permalink) Old 02-15-2018, 09:26 AM Thread Starter
New Member
 
Join Date: Feb 2018
Location: Rushford, MN
Posts: 4
 
Thanks Guys,

I will definitely plug the drain hose. Anybody switch to a manual choke ? or am i barking up the wrong tree there ?
fathead is offline  
post #6 of 16 (permalink) Old 02-15-2018, 10:24 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,123
 
Seems to be the mod to make! I really can't offer much on that as I have FI. Also went with a big bore on mine!

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #7 of 16 (permalink) Old 02-15-2018, 01:25 PM
Moderator
 
Bryan's Avatar
 
Join Date: Dec 2014
Location: Eastern most Iowa
Posts: 1,025
 
Quote:
Originally Posted by fathead View Post
Thanks Guys,

I will definitely plug the drain hose. Anybody switch to a manual choke ? or am i barking up the wrong tree there ?
I was going to, until I found that hose! My symptom was a long hard start after it sat unused for 5 days and longer. I thought choke as well, but since it wasn't temp related, I figured it had to be something else, then MLH1962 (Mike) turned me on to try this! It worked. It can sit for 10+days and start like a champ, as long as it's on a battery maintainer. That's another biggie, the battery drains about 30 milliamps an hour for the dash/clock memory. So it needs a maintainer on it to keep it fresh all the time.

'09 650XT H1, 72" Eagle Plow, Warn 3500 Winch. Dyna CDI box, UNI filters, A/C V-bag and console, EPI lift kit, Highlifter springs, Scat ProCar suspension seats. Rick the Rockets A frame and shock bushings. 28x12X14 Raceline Bruisers on Vision rims, on all corners. Cowling heat vents. Factory heat and defrost. RD's custom alternator kit. XTZ hood scoop and front shocks. Monster shock covers, turn signals. OEM glass sport windshield, sliding rear window, and lights, lights and more lights!
Bryan is offline  
post #8 of 16 (permalink) Old 02-15-2018, 06:58 PM
Moderator
 
Bryan's Avatar
 
Join Date: Dec 2014
Location: Eastern most Iowa
Posts: 1,025
 
Here is something I just thought of... dumb me! You have to "set" the electric choke, by pressing the gas pedal to the floor, one time, with the key on. Let up on the gas, then start! My 2009 has a sticker on the dash. I don't think 06-08 had this sticker, but they are the same and many 06-08 owners don't know this... Duh, I should have thought about this before... sorry.

'09 650XT H1, 72" Eagle Plow, Warn 3500 Winch. Dyna CDI box, UNI filters, A/C V-bag and console, EPI lift kit, Highlifter springs, Scat ProCar suspension seats. Rick the Rockets A frame and shock bushings. 28x12X14 Raceline Bruisers on Vision rims, on all corners. Cowling heat vents. Factory heat and defrost. RD's custom alternator kit. XTZ hood scoop and front shocks. Monster shock covers, turn signals. OEM glass sport windshield, sliding rear window, and lights, lights and more lights!
Bryan is offline  
post #9 of 16 (permalink) Old 02-16-2018, 05:56 AM
Administrator
 
Fairmont79's Avatar
 
Join Date: Mar 2012
Location: Kingman, AZ 86409
Posts: 7,123
 
I keep forgetting the 650 trick, Us old guys forget things! LOL

2009 700EFI XTX, , AC Winch, 2010 Dust Shield EPI Sport Utility Clutch Kit , Street Legal, Cage chopped 2 ", Aluminum Diamond Plate Trim, Relocated Factory Bladders with covers, 5 Pt. Harness installed, Bed Tiedown System, Scat Pro-Car Seats, Secondary Battery installed, Oil Pressure, Oil/CVT Temperature, Volt Meter & Water Temp Gauges installed with Dash Plate, Bighorns, ITP Black 212 Wheels. Tonneau cover. 750 Big Bore Kit, Web Cam, and Rocker Arms.

Either - Dick or RD
Fairmont79 is offline  
post #10 of 16 (permalink) Old 02-16-2018, 10:24 PM Thread Starter
New Member
 
Join Date: Feb 2018
Location: Rushford, MN
Posts: 4
 
Thanks guys, never knew about setting the electric choke. Gonna have to pull the cat out of the shed and try that soon.

Sent from my SM-G955U using Tapatalk
fathead is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58