Arctic Cat Prowler Forums: Prowler UTV Forum - Reply to Topic
Arctic Cat Prowler General Discussions General discussions pertaining to the Arctic Cat Prowler.

Thread: Running issue 650xt Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Arctic Cat Prowler Forums: Prowler UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-13-2011 06:40 PM
dubbus6 I am running the stock filter. Just replaced it. I will pull the carb and clean it. And pro ably just swap the electric choke for a known good one to check. I will keep you posted as to what actually fixes the problem. Thanks for all the input. And if anymore ideas comevto mind please let me know.
05-12-2011 10:50 PM
sandchris I would defiantly check the valve adjustment. However if the valves are off and causing these things it would not come and go. Valve adjustment is not a intermittent problem in other words. I personally think you are on the right track with carburation as your focus. My first guess is gonna be to check the choke for sticking. My second is to double check the carb passages especially the idle ones for crap that can only be blown out with a compressor. Not knocking on your mechanic here but his idea of cleaning your carb out and yours might not be the same. What kind of air filter are you running?



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
05-12-2011 10:30 PM
dubbus6 I have had my dealer replace the float and clean the carb. I was leaning toward the electric choke. possibly getting stuck or something. I will install a fuel filter this week to help in the future as I like to play in the deep water and mud. Should I adjust the valves just bin case...
05-12-2011 06:50 PM
sandchris Pumping the pedal is doing no good other that giving it a lot of air. The accelerator pump on the stock 650 carb is not functional. It is there but there is no linkage to make it work. With it starting by you pumping it tells me it is flooded from the choke or float sticking. So when you pump it it gets alot of air to light off the over rich mixture.
Quote:
Originally Posted by dubbus6 View Post
I did forget to mention that sometimes it is hard to start sometimes after riding a couple trails and then taking a quick break. It will crank but not start usually have to pump the pedal a couple times.


Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
05-12-2011 06:46 PM
sandchris That' what's I was leaning towards was the choke sticking. If it was mine I would pull the carb and take it apart and blow out all the passages. And would defiantly install a fuel filter.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
05-12-2011 06:46 PM
dubbus6 I did forget to mention that sometimes it is hard to start sometimes after riding a couple trails and then taking a quick break. It will crank but not start usually have to pump the pedal a couple times.
05-12-2011 06:42 PM
dubbus6 I checked plug after riding for a while. Also I do Smell gas sometimes when it was acting up. I am at around 600-1000 feet above sea level. Have not installed a fuel filter. It almost seems like the choke is stuck???
05-12-2011 12:34 AM
riddler28 x2 I would check the valves.
Good precaution anyway.
05-11-2011 10:42 PM
NEWTOTHIS I would say valves after what i have witnessed and they are easy to check.
05-11-2011 10:05 PM
sandchris Do you smell gas when it is at low speeds and acting up?
When you do a plug check is it after a high speed run or just idling around? What we need to know is what or how were you driving right before you checked the plug?
What elevation are you at?
Have you installed a fuel filter?



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58