Arctic Cat Prowler Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
`my son filled her up with diesel drained tank filled it up with good gas ran great for 5 or so miles then just died i have no fire to the spark plug any ideas what the code means and why she just stopped firing thanks for any and all help and ideas:(:confused:
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
nope i thought i might get some better info on here but thanks for the advice i thought about calling them already then i thought about this great site and all the cool guys here wanting to help each other out i would have never thought to call the dealer thanks :rolleyes:
 

·
Registered
Joined
·
95 Posts
OK, Here's what you need to do. With the key in the OFF position, remove the seat to access the fuse block. There you will find a 6-pin connector with a rubber cap on it. This is the diagnostic plug. Bend a paperclip as a jumper ( or use a wire ) and insert it into the blu/red and the blk pins. Turn the key on and the speedo will indicate the efi code. Once you get the code, contact the dealer to find out where the problem is. I am guessing that the might be a loose connector causing the system to shut down. If you get two codes and the second one is "99" that means there is no start possible.
Shut the key off and remove the jumper wire / clip. That is your diagnostic lesson for the day.
Post the results and w'ell try to help
cheers
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
ok men i done what you asked andit gave me three codes SC 12, SC 14, SC 21 took it to the dealer said the codes would not keep it from firing so what yall think please help
 

·
Registered
Joined
·
28 Posts
make sure your tipover sensor didnt fall off on you it will caus eno spark its under the passanger seat remove the middle panel and look in there, make sure its mounted to the mounting plate if that thing is turned it will shutoff all electronics. happened to my 09 xtx 700 efi
 

·
Registered
Joined
·
32 Posts
Discussion Starter #10
checked it also still in place but can they go bad because when it first started cutting out i was in a curve about 30 mph on a slope not a real bad one but will it reset it self or how dose it work i thought maybe the gas and diesel had split and when i went in the curve it sucked up the diesel but they should mix because truckers mix gas with there fuel in the winter to keep it from jellin up the dealer has no ideas as to why it want fire he keeps telling me the injector is bad and is shutting down the fire i disagree with this any thoughts?
 

·
Registered
Joined
·
95 Posts
OK, these are stored codes and WILL NOT affect the spark. The tip over sensor would give you an active code (AC23, AC99) and yes, it cuts out ignition and fuel.
My suggestion is to keep it simple, Check the spark and check the fuel. If you have both, it should run. Its possible that the dealer is correct in saying the injector may be at fault but what about the fuel pump ? Can you hear it cycle when the key is turned on ? More questions - how was the tank drained ? was the hose removed at the throttle body to clear the lines ?

code 12 = Crank Angle Sensor
code 14 = Throttle Position Sensor
code 21 = Air temp sensor
 

·
Registered
Joined
·
32 Posts
Discussion Starter #12
the tank was drained with a arkansas credit card (garden hose) lol and i did pull the hose off of the throttle body and cycle the key four or five times to get good fuel up to it the fuel pump runs when you cycle the key still the plug will not fire why will it not fire
 

·
Registered
Joined
·
95 Posts
Nope, it does not reset the system. To clear the codes, there is several steps
1-key off, install the jumper wire
2-put it in 4WD
3-hold the over-ride button
4-key on for 10 seconds
5-key off and unplug the jumper
That's all it takes to clear the codes. I am suspecting that its something simple like an unplugged wire. If there's fuel, then the concern is with spark. Re-check your wiring connectors everywhere and check the wire to the coil. Not much more I can suggest without being there. Cheers
 

·
Registered
Joined
·
32 Posts
Discussion Starter #15
ok thanks for your help catmaster we the dealer and i have checked all connections all look good my dealer has talked to cat this mornin and they are looking into it aswell my battery has finally fell below 10 volts they are charging it cause all the test say you must have a hot battery so we will go from there
 

·
Registered
Joined
·
32 Posts
Discussion Starter #16
please help my dealer also sells lawn mowers and they have pushed my rig to the back of the shop until someone can tell them whats wrong with it :mad::mad::mad::mad::mad::mad:
 

·
Registered
Joined
·
95 Posts
You may have hit it right there johnny. If the battery voltage is too low, it will not provide enough spark to the plug. Why dont you put another battery in it to confirm ? Don't need a dealer to do that for ya. Let us know
 

·
Registered
Joined
·
95 Posts
If anything, that's good news. Now your not scratching your head wondering how draining the diesel made the engine quit.
cheers. Happy riding
 
1 - 20 of 26 Posts
Top