Arctic Cat Prowler Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hay Everyone,

Love this forum, have found lots of GREAT ideas for fixes and mods. My current problem is that I jumped on my 2006 H1 Prowler the other day and it kept acting like a clutch was being pushed just after you would get rolling. I could hardly move faster than a slow walk or else it would just not move. It wasn't loosing power or anything (at least it would still rev up) it was just like someone was stepping on a clutch. I live in Carlsbad, NM, and our ATV mechanics seem to come and go so I figured if someone maybe had some ideas I might be able to start working on this thing myself? Anyway, thanks in advance for any help.

Kenneth
 

·
Registered
Joined
·
2,681 Posts
worn belt? You can change it yourself.
 

·
Registered
Joined
·
412 Posts
2nd that.. I would remove the clutch cover and check the belt before I did anything...Or It could be like I just experienced. Oil leaking through the wet clutch housing and soaking belt with oil. If you hold the gas down (not all the way) for a bit does it smoke or smell like something burning?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Ok, GREAT thanks. I have been afraid to test it so I will try holding the gas down a bit and see if it smokes. Any good links for Belt Change illustration or is it pretty much self explanatory?
 

·
Registered
Joined
·
412 Posts
I'ts somewhat self explanitory.. the only thing that can be tricky it getting the belt off the secondary clutch. It's more time consuming than hard. If you want to PM me your email I can send you the service manual that shows how to do it...
 

·
Premium Member
Joined
·
3,640 Posts
1 - 6 of 6 Posts
Top