Arctic Cat Prowler Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've read plenty of threads on no spark issues and the one in the link below describes my problem. no spark 2006 650 h1 prowler (replaced the flywheel to fix).
I purchased a project where it looks like a transmission gear went through the case and lack of lubrication tore up the cam bearings. It was missing the stator cover, stator and a couple of starter gears. I purchased used cover parts, head and new piston with rebuild cylinder.
Motor cranks with no spark, no voltage at the coil, stator and trigger test good for resistance but fail the voltage test procedures outlined in the Service Manual. I have 12 volts and a good ground at the CDI, replaced the CDI with another used one and made no difference. I have a new stator on the way but wondering about the flywheel, is there a way to test that?
I'm a DIY but everything I have with wheels (except for a few classic cars) is diesel so magneto systems are not one of my specialties!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Well I've come full circle on this issue, I had installed the trigger coil upside down! It fit quite nicely that way but when I did a trial fit with the flywheel in the magneto cover I saw the trigger coil was way off from the flywheel magnets. In my defense my machine was purchased without the magneto cover or magneto so I never removed it to have a reference. I never seen this scenario discussed in any forums so hopefully this can help someone else out.
 
1 - 2 of 2 Posts
Top