Arctic Cat Prowler Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys, new to the forum, any help would be greatly appreciated.

recently bought a 2008 prowler xt. While driving today I noticed while braking there is a clanking noice coming from what sounds like the engine area. Doesn’t make the noise any other times until the brake is engaged. It goes through gears and has all the power you can give to it. I was told by someone that it could possibly be the drive belt. Im new to owning a side by side so my knowledge on these machines is very minimal. Any info or if anyone could point me in the correct direction that would be awesome. Thanks in advance guys!!
 

·
Administrator
Joined
·
7,312 Posts
Hey guys, new to the forum, any help would be greatly appreciated.

recently bought a 2008 prowler xt. While driving today I noticed while braking there is a clanking noice coming from what sounds like the engine area. Doesn’t make the noise any other times until the brake is engaged. It goes through gears and has all the power you can give to it. I was told by someone that it could possibly be the drive belt. Im new to owning a side by side so my knowledge on these machines is very minimal. Any info or if anyone could point me in the correct direction that would be awesome. Thanks in advance guys!!
Frequent Prowler complaint! Rear parking brake chattering while braking. Anti chatter springs may be weak, although I tried many fixes, I finally just learned to live with it!
 

·
Registered
Joined
·
239 Posts
2008 has the one rear brake on the end of the Driveline. It Chatters alot. Mine has done it from day one. Some guys have converted to rear disc's on the Wheels. I just live with the broken glass noise. Going on 6k miles.
 

·
Administrator
Joined
·
7,312 Posts
2008 has the one rear brake on the end of the Driveline. It Chatters alot. Mine has done it from day one. Some guys have converted to rear disc's on the Wheels. I just live with the broken glass noise. Going on 6k miles.
That was my solution also!
 

·
Registered
Joined
·
2 Posts
maybe a lose bevel gear........ thats what seems like my problem only does it when you are going down hill or at a consistent speed
 
1 - 5 of 5 Posts
Top