Arctic Cat Prowler Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2009 flatbed model that won’t start without starting fluid when it hasn’t been used for a couple days. The fuel pump does its normal thing of coming on for a few seconds when the key is turned on. Replaced the fuel filter with a see through one and it seems like there is a fair amount of air in the filter after it hasn’t been run for a while. After it does start it will restart without any problem as long as its within a few hours of the last time it was run. Don’t know if the electric fuel pump is for initial startup only and the engine also has one or not. Not sure How to diagnose the problem. Fuel pump is $750 for this model.
 

·
Administrator
Joined
·
7,312 Posts
How is your battery? These things are very voltage sensitive hot starts are not usually a problem. I keep a battery tender on my machine.
 

·
Registered
Joined
·
1 Posts
I have my 2008 in the shop for that same problem after she sits for more than a few weeks will not start without a lot of effort. I'll post their findings when I pick her up next week.
Nick
 

·
Registered
Joined
·
239 Posts
Normal for the 2008, there is a Priming Pump on the Carb that has to be manually pumped after sitting awhile, or you will go through Batteries. I installed a Manual Choke to mine and use it as a Pump. That way I don't have to remove my Dog House.
 

·
Registered
Joined
·
239 Posts
49959
49960
 
1 - 5 of 5 Posts
Top