Arctic Cat Prowler Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys I'm new to the forum I've been having trouble with the cat not starting and if it does it dies in a few seconds. I've seen on here about the manifold boot mine was cracked I replaced it still the same. I can look down in the gas tank and I can see gas leaking back in the tank. Don't have a way to check pressure but pump sounds really strong. Seen on here about fuel regulator being bad and I know you can't get one without buying whole pump. Seen it mentioned about one that could be made to work but haven't seen what it is. If anyone can help it would be greatly appreciated.
 

·
Registered
Joined
·
3,295 Posts
so I've been of the site recently and haven't given the newbies the site rules [ or at least the way we do it]


newest Newbie duties ... bring in a load of firewood for the morning / evening fire pit BS sessions and start the morning coffee , strong but not burnt and a early start as many of us are OLD FARTS and are up early ...

welcome to the site you guys also.

important ... fill in the location and the signature lines , it helps when questions are asked so we don't have to ask what ya have & where you live so we may have an idea where to send you for help / rides/ type of ride areas / other members and who knows what else
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I had to replace the voltage regulator and battery a few months back and it ran parked till I got it out on the road and died. Took the pump out replace the seal on the end of the pump but didn't help. Had what I thought was good spark but replace the plug and so far it's running still idles a little funny but the plug must have fouled. Sorry about the signing in part I'm not much on the phone or computer. Still haven't figured out how to put that stuff on.
 

·
Registered
Joined
·
3,295 Posts
look at the top of the page above the thread on the right side of the page ... where it says used CP [control panel] click there , and then go down the list of options on the left of the new page that opens ... signature is there as is location
 

·
Administrator
Joined
·
7,221 Posts
I had to replace the voltage regulator and battery a few months back and it ran parked till I got it out on the road and died. Took the pump out replace the seal on the end of the pump but didn't help. Had what I thought was good spark but replace the plug and so far it's running still idles a little funny but the plug must have fouled. Sorry about the signing in part I'm not much on the phone or computer. Still haven't figured out how to put that stuff on.
Glad you got it running, these things are a blast when running good, not so much when not! LOL
 
1 - 6 of 6 Posts
Top