Arctic Cat Prowler Forums banner

1 - 20 of 51 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1

·
Administrator
Joined
·
7,279 Posts
Welcome to the forum! Yes, this is the best place to be! We have great members, and the site stays very active!
Followed your link,
Arctic cat prowler power issues




2009 arctic cat prowler 1000. Well I gotta ask now. This mfer ran really strong when I test drove and bought it and drove a bit. Well it started smelling hot, so I did a bit of troubleshooting and found out the coolant is low. So I opened it up and did some major burping to the system.

Finally I put the cap back on and went for a ride. Now no power hardly at all. What should I check for? Is a belt gone? Clutch? Sounds like it's bogging like the power would be going somewhere and it can't be the brakes because it rolls to a stop.

I've already pulled both injectors and watched them spray. They look good. Pulled a sensor (IAT?) On the intake and cleaned it.

I'll also add in reverse or low before and barely tapping on the accelerator you would get thrown around with power. Now not so much. Thanks!
 

·
Premium Member
Joined
·
3,640 Posts
Welcome to the site! I read the other post and hope someone here can help, I just have the old 650 carb model but there are several XTZ owners here that may have some ideas.
 

·
Registered
Joined
·
812 Posts
I had a spark plug poop out on mine and it did the same thing for no reason.
 

·
Administrator
Joined
·
7,279 Posts
I had one fail also. I now carry a spare! They just screw on the wire.
 

·
Premium Member
Joined
·
413 Posts
My 2009 XTZ 1000 loses power, unexpectedly, about once a year. A new set of plugs restores the power and response immediately. I have never had any other issues with it's performance.
 

·
Administrator
Joined
·
7,279 Posts
Great to gain some knowledge on the 1000's! I'm still learning that beast! Thanks to all!
 

·
Registered
Joined
·
77 Posts
Discussion Starter #8
Thanks guys! I actually just think I figured out I actually have a wire issue. Supposed to have a guy pick up new fluids, plugs, and wires for me and I'm going to change them out when I get home. Dang I should have found this forum first!
 

·
Registered
Joined
·
77 Posts
Discussion Starter #9
Looks like I'll need a water pump also. Weep hole on the driver side is leaking. Actually almost seems like oil though. I'll be doing some more investigating on that and taking pictures.
 

·
Administrator
Joined
·
7,279 Posts
Glad you are moving ahead on your Prowler! I can't remember on my water pump if there is a seal behind it or not, but I think there is! The water pump drive comes through the casting behind the pump. From the diagram, all I saw was a 99 cent O-Ring!
 

·
Registered
Joined
·
77 Posts
Discussion Starter #11
Oh heck yeah this thing is awesome! I want to get it into tip top shape. What diagram did you look at? Not exactly sure how the water pumps work on these, because it looks like there is a cover and then deeper in the engine it's bolted on. Unless that's the drive you're talking about. And if it is I would need that, because that's what the weep hole is on.
 

·
Premium Member
Joined
·
413 Posts
Has your XTZ had the water pump seal replaced? I had mine done as soon as the bulletin was released. I am only guessing, but I'll bet many owners were unaware or just didn't bother.


I just got a service bulletin today for all 2009 XTZs. It is for the water pump seals to be changed out with a new updated seal, so if you have one get a hold of your dealer to get in line to get your seals changed.
The above quote is from a post by forum member 'eaac' in 2009.

http://www.prowlertalk.net/forums/arctic-cat-prowler-general-discussions/1073-xtz-service-bulletin.html
 

·
Premium Member
Joined
·
413 Posts
I literally just bought it. Is it a recall, or can I get the seal(s) and do it?
I'm sure you could buy the seal, but as I recall it was a AC service bulletin and it instructed the dealers to replace the seal for free. I would have an AC dealer check your VIN to see if it was ever done. If not, you may get lucky.....and still get it done for free...
 

·
Premium Member
Joined
·
413 Posts

·
Registered
Joined
·
3,295 Posts
Yeah I did right after I posted. Sorry I should have deleted it.
it was an early production unit issue , mine was done after I told the dealer about the issue/service bulletin , he had no clue nor did the service [or better said lack of service , whole other thread needed there :( but that was a long time ago LOL ] dept.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #18
Quick update. Looks like a spark plug and cap for the rear cylinder is what she needed.

Also from what I see the fuel system doesn't like to be ran empty.

As far as the bulletin goes I guess I need to find out what to do about the water pump. I'm getting oil out of my weep hole.
 

·
Administrator
Joined
·
7,279 Posts
So, your Prowler is back to running properly I take it! Water Pump needs rebuilt or replaced. Sure would be nice if AC would list service kits, but I have not found any yet!
 

·
Registered
Joined
·
77 Posts
Discussion Starter #20
Yes it's running great, but now I have another issue to try and figure out. Always low on water and water is pushed into the overflow and leaks out. Almost sounds like a headgasket, but I did a compression and got 65 and 157 front and back respectively. Not quite sure what I should do. Bad cap maybe?
 
1 - 20 of 51 Posts
Top