Arctic Cat Prowler Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
250 Posts
Discussion Starter #1
2009 xtx, speedo jumps around while driving under 40mph. does anyone know where the vehicle speed sensor is located to see if it just needs a cleaning or maybe i just have a loose wire under the dash...
 

·
Registered
Joined
·
1,489 Posts
2009 xtx, speedo jumps around while driving under 40mph. does anyone know where the vehicle speed sensor is located to see if it just needs a cleaning or maybe i just have a loose wire under the dash...
D.J. I looked in the free repair manual that I downloaded from this website and the speed sensor is the plug in right underneath where your shift lever linkage is. Assuming your 700 is basically the same as my 650, you will see a metal cover that bolts on with two bolts. On the end of that cover you will see a black connector that is bolted on and has three wires. That black piece is your speed sensor. According to the manual you can check voltage off of that sensor to test it. If you don't have the repair manual let me know and I'll cut and paste how it says to test it......
 
  • Like
Reactions: Евгений

·
Registered
Joined
·
250 Posts
Discussion Starter #3
i do not have the service manual, if you could past it that would be awesome.
 

·
Registered
Joined
·
1,489 Posts
Speed Sensor​
(XT)​
��​
NOTE: Prior to testing the speed sensor, inspect
the three-wire connector on the speed sensor for
contamination, broken pins, and/or corrosion.

1. Set the meter selector to the DC Voltage position.
2. With appropriate needle adapters on the meter
leads, connect the red tester lead to the voltage​
lead (V); then connect the black tester lead to
the ground lead (G).
3. Turn the ignition switch to the ON position.
4. The meter must show approximately 6 DC volts.
5. Leave the black tester lead connected; then connect
the red tester lead to the signal lead pin (S).
6. Slowly move the vehicle forward or backward;
the meter must show 0 and approximately 6 DC
volts alternately.​
��​
NOTE: If the sensor tests are within specifications,
the speedometer must be replaced (see Section
9).

To replace a speed sensor, use the following procedure.
1. Disconnect the three-wire connector from the
speed sensor harness or from the speed sensor;
then remove the Allen-head cap screw securing
the sensor to the sensor housing.
2. Remove the sensor from the sensor housing​
accounting for an O-ring.
3. Install the new speed sensor into the housing
with new O-ring lightly coated with multi-purpose
grease; then secure the sensor with the
Allen-head cap screw (threads coated with blue​
Loctite #242). Tighten securely.

______________

According to the picture the wires on the connector are from left to right with it being S - G - V.
 

·
Registered
Joined
·
250 Posts
Discussion Starter #5
thanks shane, everything checks out good, maybe i have a bad connection under the dash, ill pull it apart this weekend, if everything looks fine ill just drive it above 40mph for now on :D
 

·
Registered
Joined
·
2,681 Posts
DJ I have a arctic cat shop manual for the 700 you can use
 

·
Administrator
Joined
·
7,279 Posts

·
Registered
Joined
·
812 Posts
The issue as you are all describing was in my case the aluminum reluctor wheel in the motor was self destructing, probably my first guess and is easy to check.
 

·
Premium Member
Joined
·
3,640 Posts
Mine didn't show the wrong speed but only work intermittently, it was either working right or on 0 mph, replacing the speed sensor fixed my issue. I'm glad RD got hold of Cat and reported they had the wrong price on their website, saved me a lot of money!
 

·
Registered
Joined
·
2 Posts
2013 arctic cat f800, changed speed sensor still same problem. Replaced magnets in chain case still same problem. What next? Speedo displays wrong speed
 

·
Administrator
Joined
·
7,279 Posts
Speedometer head? Try the AC snowmobile site, not blowing you off, but we are Prowler SideXSide site,
 
1 - 12 of 12 Posts
Top