Arctic Cat Prowler Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Anybody have their belt break? Looks like it slung the weights out of the clutch too...only have 240 miles on it. Any ideas or suggestions?
 

·
Registered
Joined
·
2,390 Posts
Anybody have their belt break? Looks like it slung the weights out of the clutch too...only have 240 miles on it. Any ideas or suggestions?
Do you ride in a lot of mud? Sounds like some serious heat built up in there while the belt was slipping and then it let go. The rollers most likely got so hot the peeled the covers off of the metal inner and burned flat spots into the fixed plate. I had this happen.

Call Adam from Airdam Clutches he is the man when it comes to the CVT clutches and belts. You will be very happy with his work and will not have any future problems once he does his magic.

/// Airdam - Home

Good luck and let us know what you end up with.
 

·
Registered
Joined
·
656 Posts
Do you ride in a lot of mud? Sounds like some serious heat built up in there while the belt was slipping and then it let go. The rollers most likely got so hot the peeled there covers off of the metal inner and burned flat spots into the fixed plate. I had this happen.

Call Adam from Airdam Clutches he is the man when it comes to the CVT clutches and belts. You will be very happy with his work and will not have any future problems once he does his magic.

/// Airdam - Home

Good luck and let us know what you end up with.
I second that!:D
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
I didn't feel the belt slipping. It looks like the rollers and plastic sheets look ok. Maybe just the force slung them out. Took it all apart and looks ok. Won't know till I get the new belt on.

Haven't had good luck...broke axle...and blew whole front diff into two pieces.

I bought it to ride...not to look pretty. So yes it has been through some mud.
 

·
Registered
Joined
·
2,390 Posts
I didn't feel the belt slipping. It looks like the rollers and plastic sheets look ok. Maybe just the force slung them out. Took it all apart and looks ok. Won't know till I get the new belt on.

Haven't had good luck...broke axle...and blew whole front diff into two pieces.

I bought it to ride...not to look pretty. So yes it has been through some mud.
I only asked about the mud because a few guys have had clutch/belt issues during some deep mud crossings. I hear you about buying it to ride but I think it can look good and be ridden hard also. Just a personal preference on how someones ride looks. I have no issues with mud, rocks, sand, water, or any type of riding. I have had to gusset and reinforce just about every part on my XTZ because nearly everything has broke during testing. I hope your clutch and rollers are ok and post up the outcome when you get her fixed.
 
1 - 5 of 5 Posts
Top