Arctic Cat Prowler Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
I've got "EFI" flashing on my dash display over and over again. I followed directions to get the codes (SC 15, AC 00 and AC 15) and tried to clear them but was unable. Anyone know what the codes mean?
2009 Prowler 700 XTX EFI
 

·
Registered
Joined
·
2,390 Posts
I've got "EFI" flashing on my dash display over and over again. I followed directions to get the codes (SC 15, AC 00 and AC 15) and tried to clear them but was unable. Anyone know what the codes mean?
2009 Prowler 700 XTX EFI
Check some of your connections like your fuel pump under the pax seat and make sure they are all good. As far as the codes go I can't help you. You can give Chris from EAAC a call and he may be able to help you with this. Eastern Arizona Arctic Cat 1-800-293-1586
 

·
Registered
Joined
·
95 Posts
The codes are as follows
AC00 = no fault
SC15 = stored code for water temp sensor failure
AC15 = active code for water temp sensor
I would suspect there is either a faulty water temp sensor or poor connection at the sensor. Check the connection that it isn't loose. trace the wire as best as possible to make sure it isnt rubbing against the frame or something else. Give the wires a tug to make sure it isn;t loose in the connector. Worst case, replace the water temp sensor.
Good luck
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5 (Edited)
Thanks Catmaster. I appreciate your help, eh.

Update: I found that the temperature sensor was disconnected. I plugged her in and the codes are gone! Thanks all.
 

·
Registered
Joined
·
2,681 Posts
Another GREAT save by one of the people on here!
 
1 - 8 of 8 Posts
Top