Arctic Cat Prowler Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
to all of you that have warranty and you have diff leaking seals

after the 3rd time in the last month 1/2 with both front seals leaking on my xtx and my brother`s xtz same issue (twice front once rear)

we have talked to his dealer
he has been selling prowlers ever since they are produced,he changes once the seal on warranty and after that he replaces the axles witch ac warranty aproves and he says that it has resolved all his issues

so i got my dealer that is pretty new on the market to change my both axles what he agreed to after he talked with the service rep from my brother`s dealer


if you have your dealer wanting to change the seals more then once might want talk them to change the axels,

brought the cats in yesterday to my dealer to get that done so i will keep you guys updated on the outcome
 

·
Registered
Joined
·
2,390 Posts
Good point and on the XTZ mid year 2010 down to 2009 they redesigned the rear axle so you are wasting your time if the seal is replaced under warranty. The seal is not the problem. If you have the mid year 2010 or newer XTZ you have the new axles. You can tell by looking at the rear inner near the diff it should be white.
 

·
Registered
Joined
·
733 Posts
How many Km's on your xtx?
 

·
Registered
Joined
·
222 Posts
Discussion Starter #5
Good point and on the XTZ mid year 2010 down to 2009 they redesigned the rear axle so you are wasting your time if the seal is replaced under warranty. The seal is not the problem. If you have the mid year 2010 or newer XTZ you have the new axles. You can tell by looking at the rear inner near the diff it should be white.
will tell that to my brother to look out for the whit inner thing
 

·
Registered
Joined
·
733 Posts
Wow! I really hope I don't encouter this kind of problem.. my 2010 xtx only has about 580 on it.. no probs yet (knock on wood). Hope they fix your problem with the axle change out.. that must be frustrating. I'm going to add a the extra bellows on both the front and rear diffs to hopefully take some of the stress of those seals.. let us know how it all works out. Have you been getting any trips in with all this snow?
 

·
Registered
Joined
·
222 Posts
Discussion Starter #7
Wow! I really hope I don't encouter this kind of problem.. my 2010 xtx only has about 580 on it.. no probs yet (knock on wood). Hope they fix your problem with the axle change out.. that must be frustrating. I'm going to add a the extra bellows on both the front and rear diffs to hopefully take some of the stress of those seals.. let us know how it all works out. Have you been getting any trips in with all this snow?
aint fun cause every two rides it goes back to dealer but once i am riding it i forget about the probs,this winter is exceptionaly mild for us
we barely dont have snow i would say we have about 1 foot left only on the ground so we ride every weekend since the hunting season over

you guys had a **** load of snow lately :eek: in the atlantic
 

·
Registered
Joined
·
733 Posts
Ya we sure do have a pile of snow here!! about 5 feet at least.. at my camp in Sussex WAY more than that!! been a good year for the snowmobiles! lol I can't wait to get out on the prowler but i'm sure we'll be waiting for a while for it to all melt. I'll try and upload a pic of my prowler on the path I dug out yesterday just to get it out of the shop... it took a couple hours to dig it out and the snow is almost taller than the bike....
 

·
Registered
Joined
·
222 Posts
Discussion Starter #9
Ya we sure do have a pile of snow here!! about 5 feet at least.. at my camp in Sussex WAY more than that!! been a good year for the snowmobiles! lol I can't wait to get out on the prowler but i'm sure we'll be waiting for a while for it to all melt. I'll try and upload a pic of my prowler on the path I dug out yesterday just to get it out of the shop... it took a couple hours to dig it out and the snow is almost taller than the bike....
sure would be nice too see those pics,
over here we ride in federated trails (now that they allow sxs less then 64" wide) so no matter how much snow the dozer grooms the trails every week so we are good all winter long
 

·
Registered
Joined
·
174 Posts
Good point and on the XTZ mid year 2010 down to 2009 they redesigned the rear axle so you are wasting your time if the seal is replaced under warranty. The seal is not the problem. If you have the mid year 2010 or newer XTZ you have the new axles. You can tell by looking at the rear inner near the diff it should be white.
say that again? my seals leak like no other, and i'm positive its the seals. they have been replaced, didn't leak for a couple trips, now they are leaking again.
 

·
Registered
Joined
·
2,390 Posts
say that again? my seals leak like no other, and i'm positive its the seals. they have been replaced, didn't leak for a couple trips, now they are leaking again.
LOL
Ok here you go.......Good point and on the XTZ mid year 2010 down to 2009 they redesigned the rear axle so you are wasting your time if the seal is replaced under warranty. The seal is not the problem. If you have the mid year 2010 or newer XTZ you have the new axles. You can tell by looking at the rear inner near the diff it should be white.

I should have been more specific. If you have never had the axles changed out to the new style axles your wasting your time.
 

·
Registered
Joined
·
2,390 Posts
say that again? my seals leak like no other, and i'm positive its the seals. they have been replaced, didn't leak for a couple trips, now they are leaking again.
What year is your XTZ? Do you have the new axles? If your seals are going out that fast there is more to the problem.
 

·
Registered
Joined
·
174 Posts
mine is the first year XTZ, i don't think they are new axles. Its just my drivers-side seal that leaks. When I had my very first trip with it, that shaft popped out, and i got a new o-ring for the shaft, thats it.
 

·
Registered
Joined
·
2,390 Posts
mine is the first year XTZ, i don't think they are new axles. Its just my drivers-side seal that leaks. When I had my very first trip with it, that shaft popped out, and i got a new o-ring for the shaft, thats it.
I have been down this road many times. It's not your seals that are bad it is the axles and the length that is causing rear diff fluid to seep out and you can replace all of the seals you want it is only a temporary fix for the problem. Send me a picture of your seal leak close up with a few different angles if you can. The rear axle has been superseded with a new part and I am 99.9% sure this will fix your problem. I could be wrong but I have looked at at least 5 XTZ's that share the problem and all of them were the axle design leading to the seal leak. The 3 o-ring fix is bullshit and was just a way to buy Arctic cat some time to design a new axle for the XTZ.

Let's get this figured out for you.
 

·
Registered
Joined
·
174 Posts
I'll get some pics posted up tomorrow. Thanks guys! I'll even put some pics of my new BMP exhaust I just got today! looks awesome.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #17
LOL
Ok here you go.......Good point and on the XTZ mid year 2010 down to 2009 they redesigned the rear axle so you are wasting your time if the seal is replaced under warranty. The seal is not the problem. If you have the mid year 2010 or newer XTZ you have the new axles. You can tell by looking at the rear inner near the diff it should be white.

I should have been more specific. If you have never had the axles changed out to the new style axles your wasting your time.
hey flying 121, is it just the rear axles that they redesigned the axels cause on my brother and my buddy xtz's(both 2009) they have front and rear leaking?
 

·
Registered
Joined
·
2,390 Posts
hey flying 121, is it just the rear axles that they redesigned the axels cause on my brother and my buddy xtz's(both 2009) they have front and rear leaking?
As far as I know it was just the rear on the XTZ. I will look into it later today.
 
1 - 20 of 26 Posts
Top