Arctic Cat Prowler Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
682 Posts
Discussion Starter #1
My 06 xt has been a very good machine, but recently the digital dash has been acting up. Occasionally I will be running along and the dash will shut off and only the word volt will come up. The only way to get it off is to turn the key off. Only for a second but it still has to be turned off. Anyone have any suggestions. I was told that the battery may be low,but i have one of those static batteries from hunterworks and it is fully charged. Any help would be appreciated. I have an xtz ordered but i would like to have it fixed for the new owner.
 

·
Registered
Joined
·
682 Posts
Discussion Starter #3
dash malfunction

Thanks Warlock. If i can't get this one fixed i will be interested in yours. Waiting on some info so maybe a easy fix.Give me a few days to see if anyone has anything to offer.
 

·
Registered
Joined
·
1 Posts
check the fuses under the seat.. my 08 xtx seems to do the same thing once and a while, and i've narrowed it down to the fuses coming almost out of the holder
 

·
Registered
Joined
·
85 Posts
My 06 xt has been a very good machine, but recently the digital dash has been acting up. Occasionally I will be running along and the dash will shut off and only the word volt will come up. The only way to get it off is to turn the key off. Only for a second but it still has to be turned off. Anyone have any suggestions. I was told that the battery may be low,but i have one of those static batteries from hunterworks and it is fully charged. Any help would be appreciated. I have an xtz ordered but i would like to have it fixed for the new owner.
had it happen to mine if i use too much juice...running lights , heater , wiper at same time and letting it idle too long while doing something like fix a fence. or if I use sprayer and just putt around spraying and use too much voltage. I just charge battery back up and am good to go
 

·
Registered
Joined
·
338 Posts
Hey guys theres a great big spot under the drivers seat to put a full size battery just need to move a few little things.
 

·
Registered
Joined
·
21 Posts
DigitalDash

I have a 2012 HDX and the dash lights up but does not display anything. I have checked the fuses and they look ok, any ideas??
 

·
Administrator
Joined
·
7,335 Posts
Looking back, it seems the mostly culprit is low voltage, battery should have 12.5 to 12.8 volts with the engine off, running should jump up to 14.5 to 15 volts with no lights or accessories turned on. Has this been a reoccurring issue?
 

·
Premium Member
Joined
·
3,643 Posts
Occasionally my speedometer drops to 0 and won't work again until I shut it off, no problem with rpm mode.
 

·
Registered
Joined
·
432 Posts
Occasionally my speedometer drops to 0 and won't work again until I shut it off, no problem with rpm mode.
Mine will do same thing occasionally? Restart with it in neutral and works just fine?:confused:
 

·
Premium Member
Joined
·
3,643 Posts
Mine just starting doing it within the last year, when it warms up outside I'm going to check the connections behind the dash for corrosion. I've checked about all the others and put dielectric grease on them.
 

·
Premium Member
Joined
·
8,040 Posts
Mine just starting doing it within the last year, when it warms up outside I'm going to check the connections behind the dash for corrosion. I've checked about all the others and put dielectric grease on them.
I would check the connections.........or I guess the dash could be going bad.
 

·
Registered
Joined
·
21 Posts
Just happened this weekend, had a hard time starting. Finally got it going then noticed no dash display, charged battery but still nothing. Machine runs okay.
 

·
Administrator
Joined
·
7,335 Posts
Maybe it hates the cold! LOL Bad connections usually show as intermittent problems, I think I'll follow suggestion's and use di-electric grease on mine!
 

·
Registered
Joined
·
1,489 Posts
I had to replace my dash when it had no display, but lighted up.
 

·
Administrator
Joined
·
7,335 Posts
Now go play hotrod! Stay warm, stay safe!
 

·
Registered
Joined
·
1,489 Posts
I finally disconnected the battery so the computer could reset and it works fine now, Thanks for replies!
Glad that worked for you. I tried that but with no luck. So I had to buy a new one. They aren't cheap.
 
1 - 20 of 23 Posts
Top