Arctic Cat Prowler Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
277 Posts
Discussion Starter #1
Hi. Just bought a used '07 XT650 a couple weeks ago. Really had it out for the first time yesterday. Radiator was full. Temps in the high 60's to low 70's. Wasn't running that hard. Fan came on alot. Ran for a long time before it went off. But, it did go off. No white smoke in the exhaust that I could see, no oil in water or water in oil that I could see. Never overheated. Does this seem about normal?
 

·
Registered
Joined
·
46 Posts
my 07 H1 seems to do the same thing... i notice it more when we are riding thru snow or getting stuck in mud. My cousins 08 650 actually got hot and the gauge went funking... after we rode he checked his and had a lot less anti freeze in it and mine was fine. hope this helps... just keep checkin if your worried
 

·
Registered
Joined
·
140 Posts
When I had my 650 the fan ran alot too. I switched to Engine Ice in the radiator to keep the temps down. I think the fan running alot is fine. As long as it isn't overheating......................
 

·
Registered
Joined
·
1,048 Posts
The 650 doesn't have a built in oil cooler like the 700, so it will run a bit hotter. You can go to your dealer and have him order you an oil cooler kit, p/n 1436-057. It's made for the 08 and 09 650;s, but I think it will fit the 07.
 

·
Registered
Joined
·
277 Posts
Discussion Starter #5
Good to know guys. Thank you so much! I'll be switching to Engine Ice soon. Will also look into the oil cooler. Thanks again!
 
1 - 5 of 5 Posts
Top