Arctic Cat Prowler Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
Ok. Bought my prowler new a yr ago this month. Filled it up with gas then. Have only put 58 miles on it. Ran fine last fall and through the winter. I went to take the snow plow off yesterday and check everything over and take it for a quick run down the road. When I would get on the gas it would bog out around 25-30 mph. Would bad gas cause this? It idles fine just kinda bogs out almost like a carb machine would if the carb was gummed up. This is a 550 efi prowler. Just wondering what your thought might be on this. Thanks for any input you might have.:confused:
 

·
Registered
Joined
·
3,295 Posts
check for vacuums /air leaks , and yes bad gas can do that also
 

·
Registered
Joined
·
20 Posts
I've got an 09 and had a similar problem. I cleaned the air cleaner and put a fresh plug in at the same time.... no more problems. Not sure which fixed it. But I carry a spare plug now...
 

·
Registered
Joined
·
812 Posts
If it was filled up to the top the gas will not go bad that fast. I filled mine up last November and take it to the store on occasion, but it has sat for the last 3 months with a 1/4 tank and my 1000 is fine.
 

·
Registered
Joined
·
3,295 Posts
I have learned to put stabul in all my non auto uses .. chain saws, mowers, Prowler ect.ect. 'cause ya never know when it's going to be stored for a while I just add it to the 5 gal jug when I fill it and then all the tools n toys get it even if I split it out for two stroke mixing in another gas can
 
1 - 5 of 5 Posts
Top