Arctic Cat Prowler Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
So decided to take the XTZ for its first spin around the back forty a few minutes ago. Got stuck, and when i got back to the house started cleaning the bike. There was way to much mud still caked up on the tires so wanted to take it for a quick spin around the yard to throw off the mud on the tires. Did a quick start (didnt let fuel injection start up fully, first time to do this) and started heading around the yard. Got about 30 yards and then the engine started making this awful grinding noise and lost power (speed started reducing). stopped fully and then gave it some more gas and it acted fine again. has anybody come across this problem. It seemed like it popped out of gear is what the grinding noise sounded like, but i never hit the shifter before the noise and even after i stopped i never hit the shifter again. anybody else have this happen?? Hoping this was just a small glitch
 

·
Registered
Joined
·
95 Posts
Depending on the amount of mud underneath, you think maybe someting jammed up in the shifter area ?
Has this happened again since your ride ?
 

·
Registered
Joined
·
561 Posts
depending on the year I bet it's your tranny. My buddy just in the process of replacing his on his dime. think he said it was 2400 for the short block. kept popping out of gear.
 

·
Registered
Joined
·
812 Posts
My shifter was super sensitive to index
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Fat Cat: you think that it would be the transmission with only 2hrs on this bike? If so that would be some aweful poor quality, but i doubt and hope thats not what it is.

Catmaster: yeah it happened a second time two days ago. Shifted from L to H and it we for a few feet and then started grinding. I let the RPM drop and then it drove just fine.

Are yall's prowlers hard to shift into gear somtimes. Sometimes when going from R to L i have to rev up the engine a little bit to get it to slip into gear. Its like it wont go past H until i give the engine some revs. Potato head thinks it might just be linkage in the shift cable. It did sit on the showroom floor for over a year and there is no telling how many people jumped in and shifted it back and forth a few times. So im hoping this is what the problem is since it seems to be an easy solution. What are yall's thoughts?
 

·
Registered
Joined
·
3,295 Posts
they are very picky about being in gear .. v/s just slightly in gear if that makes sense
zero MPH / stopped to shift it and make sure it's get in before proceeding with power or you hear/feel the tranny slip gear grind
 

·
Registered
Joined
·
35 Posts
Discussion Starter #7
yeah thats kinda what i was thinking too. this last time when i put it in H and i started giving it gas it didnt feel like it was really in H then it started grinding. Ill just watch myself more carefully when shifting and see if the problem persists.
 

·
Registered
Joined
·
1,489 Posts
Maybe the shift linkage just needs a slight adjustment. If that doesn't work, I would take it back to your dealer if it is still under warranty.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #9
Yeah I think I'm going to just let the dealer look at it. I'm about to order my winch and I'm just gonna let them install it. Then they can look at the linkage, check the efi error code out, and make sure everything else is up to snuff. Went to crank it up today and it took 4 tries to keep it running because it kept killing on me. Not sure what the hell that's about but my first runs with this bike sure is popping up a lot of quirks. Never had a new bike have so many minor issues. Going to just tell the dealer to do a top to bottom overlook at it because there's just too much crap heppening right now.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #10
i feel like i am so damn snake bit on this bike. got my new sport seats in today. have been anxiously awaiting these, but just my luck they are not what i was expecting. Im sure they might be more comfortable for someone that has a smaller frame, but for me the side bolsters on the seat part jab into the back of my thighs and lower butt. the back feels good but i kept going back an forth from new driver seat and oem passenger seat and every time i felt more comfortable in the oem seat. got to call arctic cat tomorrow to see about returning them :( Really cant wait to take this bike on a real ride to really see what its about. all these minor things popping up with 2 hrs of yard circling sucks.
 
1 - 10 of 10 Posts
Top