Arctic Cat Prowler Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
583 Posts
Discussion Starter #1
Figured I would adjust the valves today hoping to cure my hard to start problem. While I was in there I noticed the water temp sensor was unhooked, also found the rubber boot connecting the carb to the airbox was loose at the carb. No dirt inside the carb, and the filter was filthy so I don't think it was unhooked long. The temp sensor however looked like it's been off awhile. Anyway, adjusted the valves a little on the tight side then fired her up probably 20 times with not one problem. The valves werent real far out but seems to make a difference.
 

·
Registered
Joined
·
618 Posts
Please keep us posted on the starting, especially once it gets hot. That is when mine doesn't want to spin over right away.
 

·
Registered
Joined
·
583 Posts
Discussion Starter #5
Please keep us posted on the starting, especially once it gets hot. That is when mine doesn't want to spin over right away.
Mine too, I let it idle until the fan kicked on then started it up several times without a problem. Even let her cool down a little and tried again without a hitch.
 

·
Registered
Joined
·
583 Posts
Discussion Starter #7
Please keep us posted on the starting, especially once it gets hot. That is when mine doesn't want to spin over right away.
Went for a ride today, about 4 miles offroad and 3-4 blacktop. Tried it hot then let it cool a few minutes and tried again several times with no starting issues. Before the starter would just hum maybe 2 out of 3 times I hit the key. The only problem is, and this might just be my imagination, but it seems like its down just a hair on power.
 
1 - 7 of 7 Posts
Top