Arctic Cat Prowler Forums banner

1 - 20 of 63 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
i'm Greg and live in Southwest Louisiana. I have a 2008 prowler 650 utv, and after using it to keep a strain on a ditch witch it starting making noise like maybe I messed clutch up? not sure how to tell if its the belt or clutch, thought maybe I could get some advice. I started next day and had to start in neutral because wanted to move like clutch was ingaged. once warming new neutral, shut off and started in forward and it took off so I could get home. just seems like clutch or belt is problem, lets see what you all have to say. I appreciate any help you all can give me.
 

·
Registered
Joined
·
561 Posts
I would say ur belt is toast. The rollers in your primary are probable all sideways too. Scared the crap out of me when my belt blew. It stopped the machine dead. almost went end over end. Thank god for the seat belt.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
well thinking belt myself but why would it run good when I drove home from down the road once I started it in gear and was moving. but couldn't stop like clutch wasn't working? maybe the belt being bad could be causing all this problem? Oh and I never wear seat belt, you have me thinking.
 

·
Registered
Joined
·
432 Posts
well thinking belt myself but why would it run good when I drove home from down the road once I started it in gear and was moving. but couldn't stop like clutch wasn't working? maybe the belt being bad could be causing all this problem? Oh and I never wear seat belt, you have me thinking.
Welcome to the forum! Should be able to get the info here!:)
 

·
Founding Member
Joined
·
3,867 Posts

·
Premium Member
Joined
·
3,640 Posts
I'm trying to remember if I read somewhere the the one-way bearing could cause this. If the idle is set too high it will also try to engage the clutch, but that wouldn't explain the noise.
 

·
Premium Member
Joined
·
3,640 Posts

·
Administrator
Joined
·
7,232 Posts
Mike from Missouri, I broke down in Rolla Missouri back in 1996, I was going to LA for the Hot Rod magazine Power Tour. Nicest bunch of people I have ever encountered!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
2,681 Posts
Welcome to the forum
 

·
Premium Member
Joined
·
3,640 Posts
Mike from Missouri, I broke down in Rolla Missouri back in 1996, I was going to LA for the Hot Rod magazine Power Tour. Nicest bunch of people I have ever encountered!!!!!!!!!!!!!!!!
Good to hear, a lot of small towns in Missouri I've been to seem to be that way. I've been through Rolla a few times when I used go on summer canoe & camping trips, can't get my wife near the water anymore or in a tent. I live in a small town about 40 miles East of Kansas City along the Missouri River, towns around us call us River Rats, I should have used that for a username.
 

·
Premium Member
Joined
·
8,040 Posts
Good to hear, a lot of small towns in Missouri I've been to seem to be that way. I've been through Rolla a few times when I used go on summer canoe & camping trips, can't get my wife near the water anymore or in a tent. I live in a small town about 40 miles East of Kansas City along the Missouri River, towns around us call us River Rats, I should have used that for a username.
thats what i used to call a buddy of mine,he lives next to the ohio river.:)
 

·
Registered
Joined
·
3,295 Posts
welcome to the house .. when ya get a chance fill in your signature line so we know what ya have , will save a bunch of questions later
, also same for profile area so we know where ya are .. that info will tell us where to help send ya for parts or the ride style/ride area you live in and around
 

·
Registered
Joined
·
412 Posts
Welcome to the forum! Someone else beat me to it by posting the clutch stuck thread. I would definetely consider the one-way bearing as being the problem.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #17
I will have to figure out how to fill out signature line when I get a chance, but I have a 2008 prowler artic cat 650xt, and took clutch, belt cover off this afternoon and to me belt looks ok? I started it and it makes rattling sound, more toward back, think thats primary, but then as I revved up in neut. it got quiet and all looked good? could it be soming in back clutch? let me know if you all have any ideas I do appreciate the help.
 

·
Registered
Joined
·
733 Posts
I will have to figure out how to fill out signature line when I get a chance, but I have a 2008 prowler artic cat 650xt, and took clutch, belt cover off this afternoon and to me belt looks ok? I started it and it makes rattling sound, more toward back, think thats primary, but then as I revved up in neut. it got quiet and all looked good? could it be soming in back clutch? let me know if you all have any ideas I do appreciate the help.
Sounds to me like maybe you have some rollers turned on their sides inside your clutch. If so, easy fix.. pop off the clutch, be careful when you do the rollers will drop out and put them back in straight. Make sure you check them to make sure they aren't grooved to badly.
 
1 - 20 of 63 Posts
Top