Arctic Cat Prowler Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2,681 Posts
Discussion Starter #1
Today I was fixing one pf my horns and was checking stuff out and I couldnt believe my eyes. My crossmember under the front storage bos was broken on both sides HOLY CRAP! Ive heard of this happening but I never thought it would happen to my Prowler. So I would say you guys shouls check the front shock cross memberit brakes were the arms to support the radiatorattack to the cross member I cant believe Arctic Cat cut out the cross member out to install the radiator brackets very stipid! So you cansee why it brakes at that point!
 

·
Premium Member
Joined
·
8,040 Posts
Today I was fixing one pf my horns and was checking stuff out and I couldnt believe my eyes. My crossmember under the front storage bos was broken on both sides HOLY CRAP! Ive heard of this happening but I never thought it would happen to my Prowler. So I would say you guys shouls check the front shock cross memberit brakes were the arms to support the radiatorattack to the cross member I cant believe Arctic Cat cut out the cross member out to install the radiator brackets very stipid! So you cansee why it brakes at that point!
That's some good info JOE,last year I mention about checking all your coolant hoses and rubber lines,as I had a few rubbing the frame.I am sure other brands are the same,but a lot of the welds on the prowler are just tack welds,from diff pins to frame gussets.:confused:
 

·
Registered
Joined
·
2,681 Posts
Discussion Starter #3
Has anyone checked their front shock crossmember under your under hood storage box yet?
 

·
Premium Member
Joined
·
1,083 Posts
yeah, I checked mine out no cracks looks good ,,,,only at 100 miles lol
 

·
Administrator
Joined
·
7,281 Posts
Checked mine, and it is still intact! No cracks, and everything looks good. 2009 XTX.
 

·
Registered
Joined
·
3,295 Posts
Joe are you suggesting that this is A/C wide or specific to your model ?? [admit I have not looked into this on my XTZ unit]
 

·
Premium Member
Joined
·
3,640 Posts
Haven't found anything on mine yet.
 

·
Registered
Joined
·
561 Posts
I had cracks on the brackets that hold the rear diff in. I guess that's why it fell out. also they say there have been reports of cracks in the joints up front. But this is the 1000. they say to much torque causing the cracks.
 

·
Registered
Joined
·
2,681 Posts
Discussion Starter #10
I have heard of others breaking thats why I asked Thanks
 

·
Premium Member
Joined
·
8,040 Posts
I had cracks on the brackets that hold the rear diff in. I guess that's why it fell out. also they say there have been reports of cracks in the joints up front. But this is the 1000. they say to much torque causing the cracks.
I am sure the xtz1000 could twist some things up.:D
 

·
Premium Member
Joined
·
3,640 Posts
I checked mine again today to make sure I didn't miss anything and I don't see any cracks so I guess I'm good to go until I try something I shouldn't.:cool:
 
1 - 12 of 12 Posts
Top