Arctic Cat Prowler Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Im having a loss of power after riding for an hour and a half. The more gas I give it the slower it goes. It then starts to back fire. After 2 hrs I'm limping home. Any clues?
 

·
Registered
Joined
·
2,681 Posts
Im having a loss of power after riding for an hour and a half. The more gas I give it the slower it goes. It then starts to back fire. After 2 hrs I'm limping home. Any clues?
You need to give us something to work with? Year /make /modei miles?
 

·
Registered
Joined
·
583 Posts
Im having a loss of power after riding for an hour and a half. The more gas I give it the slower it goes. It then starts to back fire. After 2 hrs I'm limping home. Any clues?
I had a kawasaki years ago that would do that when the Cdi got hot. I've also seen junk in the carb do the same thing.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thanks guys. I appreciate the feedback. It's a 2009 Prowler 1000 xtz. I took it out several times with the same result. It runs fine until it warms up, about 45 minutes to over an hour, then starts loosing power. Thanks again for any input.
Kurt
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Oh, and it has about 5200 miles on it. My top speed is 45 mph. I would think it would have more b*%ls than that. Thanks again.
 

·
Registered
Joined
·
812 Posts
I would start with a fuel filter or at an extreme a coolant sensor.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
I checked the fuel filter and it was fine. Blew the gas right out of it with no problem. My top speed when cold is 45 mph. I know this thing has more b:$ls than that. New plugs and wires. There is something not right here.
 

·
Registered
Joined
·
618 Posts
Now this is all assuming you are in High range and 2 wheel drive.

The low speed I'd first check for dirty or worn clutch parts.

The loss of power after getting warm could be valves need adjusting.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
Well like I said, it starts cutting out at 45 to 50 mph. As it gets warmer the speed gets worse. There is a noticeable knocking on the passenger side of the motor. This seems to be a bit over my head since this is my first toy.
 
1 - 12 of 12 Posts
Top