Arctic Cat Prowler Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
Ok, i took my wheels off today for the first time to give the undercarriage on my 08 xtx a good cleaning. BUT some of my lugnuts stripped a little bit when coming off. I got them all back on (carefully) but there was ONE stud that snapped off. anyone else have this problem??? im thinking (and guessing) that the nuts are aluminum and the studs are steel so the metals are fusing (oxidizing)??? does anyone know a stud that cross references with the ac stud/thread pattern??? my dealer said he doesnt have a part number/listing for studs.
 

·
Registered
Joined
·
2,681 Posts
Ok, i took my wheels off today for the first time to give the undercarriage on my 08 xtx a good cleaning. BUT some of my lugnuts stripped a little bit when coming off. I got them all back on (carefully) but there was ONE stud that snapped off. anyone else have this problem??? im thinking (and guessing) that the nuts are aluminum and the studs are steel so the metals are fusing (oxidizing)??? does anyone know a stud that cross references with the ac stud/thread pattern??? my dealer said he doesnt have a part number/listing for studs.
The part number for the wheel lug stud is SKU: 0402-974
 

·
Registered
Joined
·
2,681 Posts

·
Registered
Joined
·
166 Posts
funny that you mention this today... I was changing out my wheels and tires for my sand set today and I snapped a stud on the front. It took about 30 min. to replace and its pertty easy but you will have to pull the hub off and use a torch to get the old one out and put the new one back in. They are in there pretty tight! I bought 4 studs and 4 new lugs at the dealer and it was about $15. I'm gonna carry spares with me now after seeing how easy they break
 

·
Registered
Joined
·
75 Posts
I changed all mine out due to the fact that with my paddles the studs were a little too short. I went with the Honda atv studs they seem to be stronger and they are a little longer with the same thread patten.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #7
did it snap because when you were taking them off, the nuts stripped??? I find it kinda weird. i was kinda hoping my local dealer would have snapped a few on the other side when he was replacing my front axle but no dice, he got em back on somehow! lol
 

·
Registered
Joined
·
2,681 Posts
did it snap because when you were taking them off, the nuts stripped??? I find it kinda weird. i was kinda hoping my local dealer would have snapped a few on the other side when he was replacing my front axle but no dice, he got em back on somehow! lol
When you put it back together put alittle antiseize compound on the treads and it wont happen again.
 

·
Registered
Joined
·
166 Posts
did it snap because when you were taking them off, the nuts stripped??? I find it kinda weird. i was kinda hoping my local dealer would have snapped a few on the other side when he was replacing my front axle but no dice, he got em back on somehow! lol
ya it snapped when I was taking it off. The dealer replaced the shock on that side earlier in the week and I think they overtorqued all of the lugs when putting the wheel back on because they were all REALLY tight.
 
1 - 10 of 10 Posts
Top