Arctic Cat Prowler Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I recently purchased a used 2009 arctic cat prowler 700xt. 5400 miles. I am having a few issues. Hoping to get some help :):

  • Problem with cold starting - when it is below 10 degrees it will crank over and over but not start
    • Fuel pump is kicking in upon turning key
    • Starter cranks
    • New battery was installed two months ago
    • 0w-40 oil
  • Starter clicks
    • When i turn over the machine, sometimes it starts right up, other times it clicks and acts like the starter is bound up.
    • If i release the ignition and restart sometimes it works, other times it still clicks
  • Ignition fuse blowing
    • The 10amp small ignition fuse is blowing.
    • Has happened twice, both times going approximately 40mph, when i let off the accelerator it pops.
Thinking i have multiple issues but unsure.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I should add, the previous owner had a heater and block heater installed on the prowler.
 

·
Registered
Joined
·
7 Posts
I realize the thread is a couple weeks old but I just saw it. Hopefully you've got the problem resolved. If not...my 09 700 XTX had the same cold start issue. Good battery, fuel pump sounded normal, seemed to crank ok. If I hooked jumper cables or a battery charger to it, it would start right up. Unfortunately, I never did figure out why but didn't ride it when it was really cold anyway. A neighbor's 08 700 XTX did the same thing. He's the one who told me to hook a battery charger to it. Certainly not a fix but maybe at least a way to get it running if needed. Once I started and ran it, it would start fine....until it sat and completely cooled off.
 
1 - 3 of 3 Posts
Top